Bug 68942 - shows only american english
shows only american english
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-language (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-16 08:37 EDT by Harald Hoyer
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-16 22:42:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2002-07-16 08:37:46 EDT
# cat /etc/sysconfig/i18n 
LANG="de_DE.UTF-8" 
SUPPORTED="en_US.UTF-8:en_US:en:de_DE.UTF-8@euro:de_DE:de_DE.UTF-8:de" 
SYSFONT="LatArCyrHeb-16"
Comment 1 Brent Fox 2002-07-16 11:59:35 EDT
Fixed in 0.9.4-2.  Thanks for your report.
Comment 2 Harald Hoyer 2002-07-16 12:20:15 EDT
shouldn't we remove @euro? X does not understand this and for utf-8 this is not
needed...
Anyway, there are no selectors for the charset and no checkbox for euro.
Also, you should be able to set this per user... $HOME/.i18n ??
see /etc/profile.d/lang.sh
Comment 3 Brent Fox 2002-07-16 16:18:52 EDT
I don't know if we should remove @euro or not.  redhat-config-language just
reads in what is in the /etc/sysconfig/i18n file.  My guess is that anaconda put
it there, so you should open a bug against anaconda to see what they want to do
about it.
Comment 4 Brent Fox 2002-08-01 08:56:18 EDT
Closing since removing @euro is beyond the scope of redhat-config-language.  The
original problem has been fixed.
Comment 5 Michael Schwendt 2002-08-04 23:00:30 EDT
$ rpm -q redhat-config-language
redhat-config-language-0.9.6-3

$ cat /etc/sysconfig/i18n 
LANG="en_GB.UTF-8"
SUPPORTED="en_GB.UTF-8:en_GB:en:en_US.UTF-8:en_US:en:de_DE.UTF-8:de_DE:de"
SYSFONT="LatArCyrHeb-16"

$ redhat-config-language
['en_GB.UTF-8', 'en_GB', 'en', 'en_US.UTF-8', 'en_US', 'en',
'de_DE.UTF-8', 'de_DE', 'de']

* Please select the default language for the system.

  English (Great Britain)
  English (USA)

[ OK ]

Not that I would want "German (Germany)" as default language, but why doesn't it
allow me to choose that.

Note You need to log in before you can comment on or make changes to this bug.