Bug 689423 - [abrt] Zim-0.48-1.fc14: notebookdialog.py:339:do_remove_notebook:TypeError: iter should be a GtkTreeIter
[abrt] Zim-0.48-1.fc14: notebookdialog.py:339:do_remove_notebook:TypeError: i...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
14
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Weyl
Fedora Extras Quality Assurance
abrt_hash:b511d170
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-21 09:41 EDT by Eric Reitmaier
Modified: 2011-03-22 11:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-22 11:32:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (550 bytes, text/plain)
2011-03-21 09:41 EDT, Eric Reitmaier
no flags Details

  None (edit)
Description Eric Reitmaier 2011-03-21 09:41:02 EDT
abrt version: 1.1.17
architecture: i686
cmdline: /usr/bin/python /usr/bin/zim
comment: I had created some Notebooks and wanted to clean them up, by removing.
component: Zim
executable: /usr/bin/zim
kernel: 2.6.35.11-83.fc14.i686
package: Zim-0.48-1.fc14
reason: notebookdialog.py:339:do_remove_notebook:TypeError: iter should be a GtkTreeIter
release: Fedora release 14 (Laughlin)
time: 1300714683
uid: 500

backtrace
-----
notebookdialog.py:339:do_remove_notebook:TypeError: iter should be a GtkTreeIter

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/zim/gui/notebookdialog.py", line 339, in do_remove_notebook
    model.remove(iter)
TypeError: iter should be a GtkTreeIter

Local variables in innermost frame:
a: (<gtk.Button object at 0x9e8b3ec (GtkButton at 0x9c2a6d0)>,)
model: <NotebookTreeModel object at 0x9e8b284 (GtkListStore at 0x9d66060)>
self: <NotebookDialog object at 0xb72232d4 (zim+gui+widgets+Dialog at 0x9e6c020)>
iter: None

How to reproduce
-----
1. Starting Zim
2. Removing a Notebook
3.
Comment 1 Eric Reitmaier 2011-03-21 09:41:05 EDT
Created attachment 486613 [details]
File: backtrace
Comment 2 Robin Lee 2011-03-21 11:08:18 EDT
Please upgrade Zim to the latest 0.50-2 and try again. I can't reproduce this using that latest version.
Comment 3 Eric Reitmaier 2011-03-22 11:09:47 EDT
Done. Cannot reproduce either.

Note You need to log in before you can comment on or make changes to this bug.