Bug 68964 - Italic fonts rendered incorrectly
Summary: Italic fonts rendered incorrectly
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: qt (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-07-16 15:40 UTC by Fortepianissimo
Modified: 2007-04-18 16:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-26 02:12:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snapshot of bad italic fonts (19.19 KB, image/png)
2002-07-16 15:41 UTC, Fortepianissimo
no flags Details

Description Fortepianissimo 2002-07-16 15:40:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020715

Description of problem:
See the attached png file.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot in KDE
2.there you go
3.
	

Additional info:

Not sure which component to blame. Let me know if you want to know more info.

Comment 1 Fortepianissimo 2002-07-16 15:41:32 UTC
Created attachment 65545 [details]
snapshot of bad italic fonts

Comment 2 Ngo Than 2002-07-16 18:56:42 UTC
Owen, i think it should be a bug in fontconfig?

Comment 3 Owen Taylor 2002-07-16 20:18:26 UTC
Almost certainly a bug in the Qt patch for Xft, not in fontconfig.

I can't reproduce the problem here ... do we have any idea of which
fonts it is that trigger the problem?


Comment 4 Fortepianissimo 2002-07-17 04:02:14 UTC
It didn't seem to be specific to a particular font; but for the snapshot it's
Microsoft Verdana.

This happened in other KDE applications as well, e.g., konqueror, kmail, etc.

BTW these are the relevant packages I installed:

fontconfig-0.0.1.020626.1517-3
Xft-1.9.1.020708.0036-2
freetype-2.1.2-4
qt-Xt-3.0.4-10
qt-MySQL-3.0.4-10
qt-3.0.4-10
qt-ODBC-3.0.4-10
qt-devel-3.0.4-10
qt-PostgreSQL-3.0.4-10
qt-designer-3.0.4-10

These packages were all rebuilt from SRPMS using
-O6 -march=i686

Comment 5 Owen Taylor 2002-07-23 16:50:35 UTC
OK - I tracked this down a bit - it appears that the problem
is that Xft does this when it tries to make a bitmap font
articially italic. And *ALL* fonts in KDE are ending up as 
one bitmap font - the "LucidaTypewriter" font from the
bitmap-fonts package.


Comment 6 Owen Taylor 2002-07-23 18:01:48 UTC
OK - I tracked this down a bit - it appears that the problem
is that Xft does this when it tries to make a bitmap font
articially italic. And *ALL* fonts in KDE are ending up as 
one bitmap font - the "LucidaTypewriter" font from the
bitmap-fonts package.

Comment 7 Owen Taylor 2002-07-23 18:47:24 UTC
The fonts-at-an-angle problem is fixed with a patch extracted
from freetype CVS in freetype-2.1.2-5 (currently building). 
Now, we just need to figure out why all the fonts are 
LucidaTypewriter.

Comment 8 Owen Taylor 2002-07-23 20:13:57 UTC
OK, I have a qt fix now ... it seems to be the 

 sample.unicode() != 0

issue again. Building a new qt on my machine to test
the fix.

Comment 9 Owen Taylor 2002-07-23 21:07:40 UTC
qt-3.0.5-3 (now building) fixes these issues; main remaining Qt
font issue is the font listing not listing the right things.


Comment 10 Fortepianissimo 2002-07-26 02:12:26 UTC
This is to confirm that

freetype-2.1.2-5
qt-3.0.5-3

together fixed the problems. Thanks guys!

Comment 11 Jay Turner 2002-09-03 18:24:55 UTC
Closing out as user confirms fix.


Note You need to log in before you can comment on or make changes to this bug.