Bug 689689 - Dependency Problem
Summary: Dependency Problem
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: evince
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Kašík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 689743 690045 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-22 06:22 UTC by David Le Sage
Modified: 2011-03-30 08:16 UTC (History)
6 users (show)

Fixed In Version: poppler-0.16.3-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-29 03:58:08 UTC


Attachments (Terms of Use)

Description David Le Sage 2011-03-22 06:22:58 UTC
Description of problem:
When I run yum update at the moment, I am seeing the following dependency resolution error:

Error: Package: evince-libs-2.91.92-1.fc15.x86_64 (updates-testing)
           Requires: libpoppler.so.13()(64bit)
 You could try using --skip-broken to work around the problem

Comment 1 Fedora Update System 2011-03-22 10:12:23 UTC
poppler-0.16.3-1.fc15,libreoffice-3.3.1.2-11.fc15,ufraw-0.18-2.fc15,vtk-5.6.1-5.fc15,apvlv-0.0.9.8-4.fc15,calibre-0.7.44-3.fc15,ease-0.4-4.fc15,epdfview-0.1.7-13.20100621svn.fc15,evince-2.91.92-2.fc15,gambas2-2.22.0-6.fc15,gdcm-2.0.16-17.fc15,gimp-2.6.11-8.fc15,gloobus-preview-0.4.1-13.fc15,gnome-commander-1.2.8.10-3.fc15,gummi-0.5.5-4.fc15,inkscape-0.48.1-4.fc15,koffice-2.3.3-2.fc15,libextractor-0.6.2-1508.fc15,OpenSceneGraph-2.8.3-10.fc15,pdf2djvu-0.7.4-7.fc15,pdf2svg-0.2.1-11.fc15,pypoppler-0.12.1-11.fc15,referencer-1.1.6-15.fc15,rubygem-poppler-0.90.8-2.fc15,texlive-2007-62.fc15,texmaker-2.1-5.fc15,texmakerx-2.0-6.fc15,tracker-0.10.3-2.fc15,vifir-0.8-1.fc15,xournal-0.4.5-12.fc15,zathura-0.0.8.2-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/poppler-0.16.3-1.fc15,libreoffice-3.3.1.2-11.fc15,ufraw-0.18-2.fc15,vtk-5.6.1-5.fc15,apvlv-0.0.9.8-4.fc15,calibre-0.7.44-3.fc15,ease-0.4-4.fc15,epdfview-0.1.7-13.20100621svn.fc15,evince-2.91.92-2.fc15,gambas2-2.22.0-6.fc15,gdcm-2.0.16-17.fc15,gimp-2.6.11-8.fc15,gloobus-preview-0.4.1-13.fc15,gnome-commander-1.2.8.10-3.fc15,gummi-0.5.5-4.fc15,inkscape-0.48.1-4.fc15,koffice-2.3.3-2.fc15,libextractor-0.6.2-1508.fc15,OpenSceneGraph-2.8.3-10.fc15,pdf2djvu-0.7.4-7.fc15,pdf2svg-0.2.1-11.fc15,pypoppler-0.12.1-11.fc15,referencer-1.1.6-15.fc15,rubygem-poppler-0.90.8-2.fc15,texlive-2007-62.fc15,texmaker-2.1-5.fc15,texmakerx-2.0-6.fc15,tracker-0.10.3-2.fc15,vifir-0.8-1.fc15,xournal-0.4.5-12.fc15,zathura-0.0.8.2-5.fc15

Comment 2 Marek Kašík 2011-03-22 11:14:15 UTC
*** Bug 689743 has been marked as a duplicate of this bug. ***

Comment 3 Marek Kašík 2011-03-23 08:51:11 UTC
*** Bug 690045 has been marked as a duplicate of this bug. ***

Comment 4 tuxor 2011-03-24 10:58:56 UTC
Another dependency problem involves these:

evince.x86_64, evince-libs.x86_64, evince-nautilus.x86_64, gimp.x86_64, gimp-help-browser.x86_64, gimp-libs.x86_64, libreoffice-calc.x86_64, libreoffice-core.x86_64, libreoffice-draw.x86_64, libreoffice-graphicfilter.x86_64, libreoffice-impress.x86_64, libreoffice-langpack-de.x86_64, libreoffice-langpack-en.x86_64, libreoffice-math.x86_64, libreoffice-opensymbol-fonts.noarch, libreoffice-pdfimport.x86_64, libreoffice-presenter-screen.x86_64, libreoffice-ure.x86_64, libreoffice-writer.x86_64, libreoffice-xsltfilter.x86_64, mysql.x86_64, mysql-libs.x86_64, mysql-server.x86_64, poppler.x86_64, poppler-glib.x86_64, poppler-utils.x86_64

basically these are evince*, poppler*, libreoffice*, mysql*, gimp* ...

Comment 5 tuxor 2011-03-25 19:04:17 UTC
I uninstalled libreoffice* and tried again "yum update". No dependency problems with update any more. BUT libreoffice still has dep problems. So new bug is Bug 690912 (https://bugzilla.redhat.com/show_bug.cgi?id=690912).

I think this Bug should be closed!

Comment 6 Marek Kašík 2011-03-28 10:03:12 UTC
Hi tuxor,

this bug will be automatically closed by Bodhi.

Marek

Comment 7 Fedora Update System 2011-03-29 03:57:37 UTC
poppler-0.16.3-1.fc15, ufraw-0.18-2.fc15, vtk-5.6.1-5.fc15, apvlv-0.0.9.8-4.fc15, calibre-0.7.44-3.fc15, ease-0.4-4.fc15, epdfview-0.1.7-13.20100621svn.fc15, gdcm-2.0.16-17.fc15, gimp-2.6.11-8.fc15, gloobus-preview-0.4.1-13.fc15, gnome-commander-1.2.8.10-3.fc15, gummi-0.5.5-4.fc15, inkscape-0.48.1-4.fc15, koffice-2.3.3-2.fc15, libextractor-0.6.2-1508.fc15, OpenSceneGraph-2.8.3-10.fc15, pdf2djvu-0.7.4-7.fc15, pdf2svg-0.2.1-11.fc15, pypoppler-0.12.1-11.fc15, referencer-1.1.6-15.fc15, rubygem-poppler-0.90.8-2.fc15, texlive-2007-62.fc15, texmaker-2.1-5.fc15, vifir-0.8-1.fc15, xournal-0.4.5-12.fc15, zathura-0.0.8.2-5.fc15, gambas2-2.22.0-7.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Giedrius Slavinskas 2011-03-29 08:04:58 UTC
I was not able to upgrade evince and libreoffice-pdfimport:

Error: Package: evince-libs-2.91.93-1.fc15.x86_64 (fedora)
           Requires: libpoppler.so.13()(64bit)
Error: Package: 1:libreoffice-pdfimport-3.3.2.2-2.fc15.x86_64 (updates-testing)
           Requires: libpoppler.so.13()(64bit)


Note You need to log in before you can comment on or make changes to this bug.