Bug 68970 - Wanted: NOPPPWATCH variable for ifcfg-ppp files
Summary: Wanted: NOPPPWATCH variable for ifcfg-ppp files
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-16 16:22 UTC by Jos Vos
Modified: 2014-03-17 02:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 20:07:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (made against initscripts 6.67) (1.86 KB, patch)
2002-07-27 19:24 UTC, Jos Vos
no flags Details | Diff
New patch for initscripts 6.90. (1.91 KB, patch)
2002-09-02 09:41 UTC, Jos Vos
no flags Details | Diff

Description Jos Vos 2002-07-16 16:22:30 UTC
Proposal:
Support a NOPPPWATCH variable (default no) to enable the possibility of not
starting ppp-watch. This requires a small patch for the ifup-ppp script (also
using pppd's "updetach" option) and a small patch for the ifdown-ppp script
(when looking at pid files etc.).  I'm using own patches now and if you are
interested, I can attach them to this bug (after some more testing).

See also bug #68969 for some background of why I'm asking this.

Comment 1 Jos Vos 2002-07-27 19:24:22 UTC
Created attachment 67364 [details]
Proposed patch (made against initscripts 6.67)

Comment 2 Jos Vos 2002-07-27 19:28:09 UTC
The attached patch (for initscripts 6.67) works for me, but probably needs a
review by RH, as I don't know all backgrounds of the current script. The new
feature is enabled by including PPPWATCH=no in the ifcfg-ppp* file. I also
needed to add "> /dev/null" to pppd, as otherwise you get all kind of output
until the process is detached.

Comment 3 Jos Vos 2002-09-02 09:41:56 UTC
Created attachment 74485 [details]
New patch for initscripts 6.90.

Comment 4 Bill Nottingham 2005-09-29 20:07:21 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.


Note You need to log in before you can comment on or make changes to this bug.