Bug 690024 - Can't change font in gedit
Can't change font in gedit
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
15
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-22 23:44 EDT by Rich Mattes
Modified: 2011-03-26 20:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-26 20:34:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Mattes 2011-03-22 23:44:01 EDT
Description of problem:
I recently upgraded my system from Fedora 14 to Fedora 15 alpha using Anaconda.  After the upgrade, gedit is not using a monospaced font, it seems to be using whatever the default GNOME font is.

Version-Release number of selected component (if applicable):
gedit-2.91.8-1.fc15.x86_64

How reproducible:
I can only reproduce this on my local machine that's been upgraded from Fedora 14.  I've tried the Alpha live desktop image in qemu and booted natively, they work fine.

Steps to Reproduce:
1. Upgrade an F14 install to F15
2. Open gedit and edit a file
3. Try changing the font in Edit->Preferences->Fonts & Colors
  
Actual results:
None of the font options in the Preferences result in a changed font, either in the preview window or in the editor.  The font always stays at the default GNOME font.

Expected results:
gedit defaults to the default GNOME monospaced font ("Monospace 11"), which can be overridden from the preferences

Additional info:
I'm not sure if this is some kind of configuration error, or really a bug in gedit.  Happy to provide any additional information.
Comment 1 Theodore Lee 2011-03-24 11:00:59 EDT
Looks like this is fixed in the latest batch of updates to gtk and GNOME (not sure which specifically).
Comment 2 Rich Mattes 2011-03-26 20:34:56 EDT
(In reply to comment #1)
> Looks like this is fixed in the latest batch of updates to gtk and GNOME (not
> sure which specifically).

I ran an update, and the problem disappeared for me too.  I guess I will close this bug since it seems like it's not an issue anymore.

Note You need to log in before you can comment on or make changes to this bug.