Bug 690055 - Displaying a ps file of size 21x28 cm, evince cuts some parts
Displaying a ps file of size 21x28 cm, evince cuts some parts
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-23 04:16 EDT by Joachim Backes
Modified: 2011-05-31 02:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-31 02:09:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the postscript file shown incomplete by evince (53.60 KB, application/postscript)
2011-03-23 04:16 EDT, Joachim Backes
no flags Details
the ODP ducument which has been printed to the ps file (18.85 KB, application/octet-stream)
2011-03-23 04:19 EDT, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2011-03-23 04:16:43 EDT
Created attachment 486975 [details]
the postscript file shown incomplete by evince

Description of problem:
I have a PS file produced by printing from an libreoffice ODP ducument (contains only 1 page). Viewing this PS file is OK with gs, gv, display  or xv. But viewing it by evince, some parts of the page are cut.

Version-Release number of selected component (if applicable):

evince-2.91.90-1.fc15.x86_64
How reproducible:
always

Steps to Reproduce:
1.evince ps-file
2.
3.
  
Actual results:
parts arew cut

Expected results:
display total page

Additional info:
Comment 1 Joachim Backes 2011-03-23 04:19:43 EDT
Created attachment 486976 [details]
the ODP ducument which has been printed to the ps file

Opening the document by libreoffice and printing into a postscript file will produce a postscript file which will be shown incompletely by evince.
Comment 2 Marek Kašík 2011-05-30 07:40:30 EDT
The problem with here is that the PS file has set PageBoundingBox smaller than the whole page. And because evince draws only the part contained in bounding box it doesn't show the area outside of this box.
I see that the document has all margins set 0.0 so it could be a bug in libreoffice. I would expect the bounding box of resulting PS to be the whole page in this case.
I'm reassigning this to libreoffice for further evaluation.

Regards

Marek
Comment 3 David Tardon 2011-05-31 02:09:15 EDT
The PageBoundingBox is taken from printer settings. E.g., with CUPS-PDF, I get

%%PageBoundingBox: 0 0 595 842

(the slide is displayed completely) and with a physical printer

%%PageBoundingBox: 11 11 584 831

(the slide is cut off at top and bottom). I suppose the slide would be cut off just as well on real print. Checking Fit to printable page on should help.
Comment 4 Joachim Backes 2011-05-31 02:20:22 EDT
(In reply to comment #3)
> The PageBoundingBox is taken from printer settings. E.g., with CUPS-PDF, I get
> 
> %%PageBoundingBox: 0 0 595 842
> 
> (the slide is displayed completely) and with a physical printer
> 
> %%PageBoundingBox: 11 11 584 831
> 
> (the slide is cut off at top and bottom). I suppose the slide would be cut off
> just as well on real print. Checking Fit to printable page on should help.

I checked this, and You are right: printing the slide will cut off top and button.

Note You need to log in before you can comment on or make changes to this bug.