Bug 69021 - mm_inline, X crashes, frequent lockups, etc.
mm_inline, X crashes, frequent lockups, etc.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-17 00:07 EDT by Andrew Jones
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-18 16:34:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Jones 2002-07-17 00:07:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
I have been suffering from frequent (sometimes multiple times daily, sometimes
every three days or so) hangs and reboots for a very long time. Usually the
machine just freezes, sometimes it reboots by itself, sometimes it freezes and
the LEDs on the keyboard flash. Of course, there's nothing in the log when i
boot the machine again. This time, though, i caught something. The log entries
follow. Generally speaking, how could i go about getting more information about
this? Null modem cable with /dev/console redirected, or what? 

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

More info to my setup: kernel 2.4.18-5 i686, but running on an AMD Athlon XP
1700+. Spacewalker AK31 motherboard. More information available on request, if
it's relevant.

Jul 17 05:24:22 server kernel: ------------[ cut here ]------------
Jul 17 05:24:22 server kernel: kernel BUG at
/usr/src/build/108423-i686/BUILD/kernel-2.4.18/linux/include/linux/mm_inline.h:71!
Jul 17 05:24:22 server kernel: invalid operand: 0000
Jul 17 05:24:22 server kernel: sr_mod ide-cd cdrom parport_pc lp parport 8139too
mii st usb-storage printer u
Jul 17 05:24:22 server kernel: CPU:    0
Jul 17 05:24:22 server kernel: EIP:    0010:[<c012f212>]    Not tainted
Jul 17 05:24:22 server kernel: EFLAGS: 00013286
Jul 17 05:24:22 server kernel: 
Jul 17 05:24:22 server kernel: EIP is at reclaim_page [kernel] 0x142 (2.4.18-5)
Jul 17 05:24:22 server kernel: eax: 00000061   ebx: c149e1f8   ecx: 00000001  
edx: 000026e1
Jul 17 05:24:22 server kernel: esi: c149e214   edi: c149e214   ebp: c02c7304  
esp: cbd09e18
Jul 17 05:24:22 server kernel: ds: 0018   es: 0018   ss: 0018
Jul 17 05:24:22 server kernel: Process X (pid: 1243, stackpage=cbd09000)
Jul 17 05:24:22 server gnome-name-server[4053]: input condition is: 0x11, exiting
Jul 17 05:24:22 server gdm(pam_unix)[1242]: session closed for user arjones
Jul 17 05:24:22 server kernel: Stack: c0224300 00000047 c02c733c 00004bf6
00000000 c02c7304 c02c74f0 00000003 
Jul 17 05:24:22 server kernel:        00000001 c013174c 00000000 c02c74f8
00000000 0000061e c013182a c02c74ec 
Jul 17 05:24:22 server gdm[1242]: gdm_slave_xioerror_handler: Fatal X error -
Restarting :0
Jul 17 05:24:22 server kernel:        00000000 00000003 00000001 00000000
00000001 c02c74ec 000001d2 c1003910 
Jul 17 05:24:22 server kernel: Call Trace: [<c013174c>] __alloc_pages_limit
[kernel] 0x7c 
Jul 17 05:24:22 server kernel: [<c013182a>] __alloc_pages [kernel] 0xaa 
Jul 17 05:24:22 server kernel: [<c0125f71>] do_anonymous_page [kernel] 0x51 
Jul 17 05:24:22 server kernel: [<c0126054>] do_no_page [kernel] 0x34 
Jul 17 05:24:22 server kernel: [<c01262aa>] handle_mm_fault [kernel] 0xca 
Jul 17 05:24:22 server kernel: [<c010853d>] handle_signal [kernel] 0x7d 
Jul 17 05:24:22 server kernel: [<c0113eca>] do_page_fault [kernel] 0x12a 
Jul 17 05:24:22 server kernel: [<c0107cc5>] restore_sigcontext [kernel] 0x115 
Jul 17 05:24:22 server kernel: [<c0107da9>] sys_sigreturn [kernel] 0xb9 
Jul 17 05:24:22 server kernel: [<c0113da0>] do_page_fault [kernel] 0x0 
Jul 17 05:24:22 server kernel: [<c0108a04>] error_code [kernel] 0x34 
Jul 17 05:24:22 server kernel: 
Jul 17 05:24:22 server kernel: 
Jul 17 05:24:22 server kernel: Code: 0f 0b 59 5e 8d 76 00 8d bc 27 00 00 00 00
8b 43 18 a9 80 00 
Jul 17 05:24:22 server kernel:  ------------[ cut here ]------------
Jul 17 05:24:22 server kernel: kernel BUG at
/usr/src/build/108423-i686/BUILD/kernel-2.4.18/linux/include/linux/mm_inline.h:51!
Jul 17 05:24:22 server kernel: invalid operand: 0000
Jul 17 05:24:22 server kernel: sr_mod ide-cd cdrom parport_pc lp parport 8139too
mii st usb-storage printer u
Jul 17 05:24:22 server kernel: CPU:    0
Jul 17 05:24:22 server kernel: EIP:    0010:[<c012ef86>]    Not tainted
Jul 17 05:24:22 server kernel: EFLAGS: 00010282
Jul 17 05:24:22 server kernel: 
Jul 17 05:24:22 server kernel: EIP is at __lru_cache_del [kernel] 0x66 (2.4.18-5)
Jul 17 05:24:22 server kernel: eax: 00000061   ebx: c149e1c0   ecx: 00000001  
edx: 00002c7d
Jul 17 05:24:22 server kernel: esi: 00000006   edi: 00003000   ebp: 151be067  
esp: c204be74
Jul 17 05:24:22 server kernel: ds: 0018   es: 0018   ss: 0018
Jul 17 05:24:22 server kernel: Process panel (pid: 4074, stackpage=c204b000)
Jul 17 05:24:22 server kernel: Stack: c0224300 00000033 c149e1c0 00000000
c012f0c5 c01310dd d2dcfe80 00000000 
Jul 17 05:24:22 server kernel:        c1038030 c02c7344 00000212 ffffffff
00009e61 000d4000 c1cfc2e0 00003000 
Jul 17 05:24:22 server kernel:        151be067 c0124ebf c149e1c0 00000004
00000000 08189000 d0a2c080 080b5000 
Jul 17 05:24:22 server kernel: Call Trace: [<c012f0c5>] lru_cache_del [kernel] 0x5 
Jul 17 05:24:22 server kernel: [<c01310dd>] __free_pages_ok [kernel] 0x2d 
Jul 17 05:24:22 server kernel: [<c0124ebf>] do_zap_page_range [kernel] 0x18f 
Jul 17 05:24:22 server kernel: [<e0857015>] ext3_mark_iloc_dirty [ext3] 0x35 
Jul 17 05:24:22 server kernel: [<c0125410>] zap_page_range [kernel] 0x50 
Jul 17 05:24:22 server kernel: [<c0127b8a>] exit_mmap [kernel] 0xca 
Jul 17 05:24:22 server kernel: [<c01160e6>] mmput [kernel] 0x26 
Jul 17 05:24:22 server kernel: [<c011a423>] do_exit [kernel] 0xb3 
Jul 17 05:24:22 server kernel: [<c0143a0b>] sys_unlink [kernel] 0xbb 
Jul 17 05:24:22 server kernel: [<c0108913>] system_call [kernel] 0x33 
Jul 17 05:24:22 server kernel: 
Jul 17 05:24:22 server kernel: 
Jul 17 05:24:22 server kernel: Code: 0f 0b 59 5e 8b 43 18 83 e0 20 0f 84 1c 01
00 00 6a 33 68 00
Comment 1 Andrew Jones 2003-06-18 16:34:21 EDT
This was probably due to a heat problem on my machine. It has not happend since
last summer. It will probably start happening again soon. :)

Note You need to log in before you can comment on or make changes to this bug.