Bug 690284 - panic: installing latest rawhide build under qemu-kvm
panic: installing latest rawhide build under qemu-kvm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-23 15:30 EDT by eric magaoay
Modified: 2013-01-09 06:49 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-23 15:57:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
console output (16.63 KB, application/octet-stream)
2011-03-23 15:30 EDT, eric magaoay
no flags Details

  None (edit)
Description eric magaoay 2011-03-23 15:30:50 EDT
Created attachment 487126 [details]
console output

Description of problem:
kernel panic while installing latest rawhide build 3.23.11 under qemu-kvm. same problem using following switch: -no-kvm / -no-kvm-irqchip / -no-kvm-pit

Version-Release number of selected component (if applicable):
Host: 
kernel = Linux fdb9 2.6.35.11-83.fc14.x86_64 #1 SMP Mon Feb 7 07:06:44 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
CPU: AMD Phenom(tm) II X4 B55 Processor
qemu.x86_64  2:0.13.0-1.fc14
Guest:
x86 using the latest rawhide build (3.23.11)

commandline: /usr/bin/qemu-kvm -kernel /home/a/m/sf/dev/i386/os/isolinux/vmlinuz -initrd /home/a/m/sf/dev/i386/os/isolinux/initrd.img -append "ks=http://192.168.5.109/a/ks/fda0-25740 console=ttyS0,115200" -drive file=/home/a/i/fda0  -localtime -usbdevice tablet -vga std -vnc :19840 -monitor stdio -name fda0-25740 -net nic,vlan=25740,macaddr=52:54:00:09:18:40 -net user,vlan=25740,hostname=fda0-25740  -m 512   -serial file:/home/a/q/z/z.qdebug 


How reproducible:
persistent

Steps to Reproduce:
1. Prepare under x86_64 F14 fedora host with guest: x86 latest build (3.23.11)
2. run command line:
/usr/bin/qemu-kvm -kernel /home/a/m/sf/dev/i386/os/isolinux/vmlinuz -initrd /home/a/m/sf/dev/i386/os/isolinux/initrd.img -append "ks=http://192.168.5.109/a/ks/fda0-25740 console=ttyS0,115200" -drive file=/home/a/i/fda0  -localtime -usbdevice tablet -vga std -vnc :19840 -monitor stdio -name fda0-25740 -net nic,vlan=25740,macaddr=52:54:00:09:18:40 -net user,vlan=25740,hostname=fda0-25740  -m 512   -serial file:/home/a/q/z/z.qdebug
3.
  
Actual results:
kernel panics

Expected results:


Additional info:
Comment 1 Bill Nottingham 2011-03-23 15:56:49 EDT
You ran out of memory.

See: -m 512 - add more.
Comment 2 Bill Nottingham 2011-03-23 15:57:22 EDT
(We're working on dropping the memory requirements of the installer, but the behavior you hit was not a bug - it's handling OOM correctly.)

Note You need to log in before you can comment on or make changes to this bug.