Bug 69053 - i810 wont start X
i810 wont start X
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
limbo
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-17 11:25 EDT by Daniel Powell
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-17 11:25:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Powell 2002-07-17 11:25:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
the i810 on this dell Optiplex wont start X. The kernel crashes when testing X 
settings.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot
2. Start X or Run Xconfigurator and test

	

Actual Results:  X wont start and wont work in test mode

Expected Results:  X should have started

Additional info:

Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 202M
agpgart: Detected an Intel i810 E Chipset.
agpgart: detected 4MB dedicated video ram.
agpgart: AGP aperture is 64M @ 0xf4000000
[drm] AGP 0.99 on Intel i810 @ 0xf4000000 64MB
[drm] Initialized i810 1.2.0 20010920 on minor 0
Unable to handle kernel NULL pointer dereference at virtual address 000000e0
 printing eip:
c012e7f4
*pde = 0aadf067
*pte = 00000000
Oops: 0000
i810 agpgart autofs 3c59x ide-cd cdrom mousedev keybdev hid input usb-uhci usb
CPU:    0
EIP:    0010:[<c012e7f4>]    Not tainted
EFLAGS: 00013a47

EIP is at unlock_page [kernel] 0x14 (2.4.18-5.58)
eax: c1218500   ebx: 00000000   ecx: c12185f8   edx: 54218500
esi: c993f000   edi: cc404800   ebp: cb387ee8   esp: cb387ed4
ds: 0018   es: 0018   ss: 0018
Process X (pid: 1166, stackpage=cb387000)
Stack: c12185f8 d09a2dcb c12185f8 c19e0f5c cd8d5800 cb387f08 d09a2e80 cc404800 
       c993f000 cfbb6ef4 cc404800 cb387f1c cfb2965c cb387f64 d09a33f0 cc404800 
       bffffc30 00000040 00000002 00000000 00000000 00000000 00000000 00000000 
Call Trace: [<d09a2dcb>] i810_free_page [i810] 0x4b 
[<d09a2e80>] i810_dma_cleanup [i810] 0xa0 
[<d09a33f0>] i810_dma_init [i810] 0x60 
[<d099e6fd>] i810_ioctl [i810] 0xbd 
[<c014ea9b>] sys_ioctl [kernel] 0xab 
[<c01092e3>] system_call [kernel] 0x33 


Code: 8b 8b e0 00 00 00 d3 ea 8d 0c d5 00 00 00 00 8b 93 d8 00 00
Comment 1 Arjan van de Ven 2002-07-17 11:36:30 EDT
fixed in more recent builds

Note You need to log in before you can comment on or make changes to this bug.