Bug 69056 - Firstboot to X on i810 fails
Firstboot to X on i810 fails
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: firstboot (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-17 11:34 EDT by Daniel Powell
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-17 11:59:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Powell 2002-07-17 11:34:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
firstboot config fails to load X

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot machine
2. X keeps recycling trying to load the Window Manager

	

Actual Results:  Non usable gui, keeps recycling. X boots WM fails to load

Expected Results:  GDM login screen

Additional info:

Jul 17 11:14:30 Barley xfs: ignoring font path 
element /usr/X11R6/lib/X11/fonts/cyrillic (unreadable) 
Jul 17 11:14:30 Barley xfs: ignoring font path 
element /usr/X11R6/lib/X11/fonts/CID (unreadable) 
Jul 17 11:14:30 Barley xfs: ignoring font path 
element /usr/X11R6/lib/X11/fonts/local (unreadable) 
Jul 17 11:14:30 Barley xfs: ignoring font path 
element /usr/X11R6/lib/X11/fonts/latin2/Type1 (unreadable) 
Jul 17 11:14:31 Barley xfs: ignoring font path 
element /usr/share/fonts/default/TrueType (unreadable) 
Jul 17 11:14:31 Barley xfs: ignoring font path 
element /usr/share/AbiSuite/fonts (unreadable) 
Jul 17 11:14:31 Barley firstboot: 
Jul 17 11:14:31 Barley firstboot: XFree86 Version 4.2.0
Jul 17 11:14:31 Barley firstboot:  (Custom Build: 4.2.0-52) / X Window System
Jul 17 11:14:31 Barley firstboot: (protocol Version 11, revision 0, vendor 
release 6600)
Jul 17 11:14:31 Barley firstboot: Release Date: 23 January 2002
Jul 17 11:14:31 Barley firstboot: ^IIf the server is older than 6-12 months, or 
if your card is
Jul 17 11:14:31 Barley firstboot: ^Inewer than the above date, look for a newer 
version before
Jul 17 11:14:31 Barley firstboot: ^Ireporting problems.  (See 
http://www.XFree86.Org/)
Jul 17 11:14:31 Barley firstboot: Build Operating System: Linux 2.4.9-e.3smp 
i686 [ELF] 
Jul 17 11:14:31 Barley firstboot: Build Host: astest
Jul 17 11:14:31 Barley firstboot:  
Jul 17 11:14:31 Barley firstboot: Module Loader present
Jul 17 11:14:31 Barley firstboot: Markers: (--) probed, (**) from config file, 
(==) default setting,
Jul 17 11:14:31 Barley firstboot:          (++) from command line, (!!) notice, 
(II) informational,
Jul 17 11:14:31 Barley firstboot:          (WW) warning, (EE) error, (NI) not 
implemented, (??) unknown.
Jul 17 11:14:32 Barley firstboot: (==) Log file: "/var/log/XFree86.1.log", 
Time: Wed Jul 17 11:14:31 2002
Jul 17 11:14:32 Barley firstboot: (==) Using config file: "/etc/X11/XF86Config"
Jul 17 11:14:35 Barley kernel: Linux agpgart interface v0.99 (c) Jeff Hartmann
Jul 17 11:14:35 Barley kernel: agpgart: Maximum main memory to use for agp 
memory: 202M
Jul 17 11:14:35 Barley kernel: agpgart: Detected an Intel i810 E Chipset.
Jul 17 11:14:35 Barley kernel: agpgart: detected 4MB dedicated video ram.
Jul 17 11:14:35 Barley kernel: agpgart: AGP aperture is 64M @ 0xf4000000
Jul 17 11:14:35 Barley modprobe: modprobe: Can't locate module char-major-226
Jul 17 11:14:35 Barley modprobe: modprobe: Can't locate module char-major-226
Jul 17 11:14:35 Barley kernel: [drm] AGP 0.99 on Intel i810 @ 0xf4000000 64MB
Jul 17 11:14:35 Barley kernel: [drm] Initialized i810 1.2.0 20010920 on minor 0
Jul 17 11:14:36 Barley firstboot: in start_existing_X
Jul 17 11:14:36 Barley firstboot: about to try
Jul 17 11:14:36 Barley firstboot: Traceback (most recent call last):
Jul 17 11:14:36 Barley firstboot:   File "/usr/sbin/firstboot", line 108, in ?
Jul 17 11:14:36 Barley firstboot:     wm_pid = startWindowManager()
Jul 17 11:14:36 Barley firstboot:   File "/usr/sbin/firstboot", line 35, in 
startWindowManager
Jul 17 11:14:36 Barley firstboot:     os.execv(path, args)
Jul 17 11:14:36 Barley firstboot: OSError: [Errno 2] No such file or directory
Jul 17 11:14:39 Barley firstboot: in start_existing_X
Jul 17 11:14:39 Barley firstboot: about to try
Jul 17 11:14:39 Barley firstboot: Traceback (most recent call last):
Jul 17 11:14:39 Barley firstboot:   File "/usr/sbin/firstboot", line 108, in ?
Jul 17 11:14:39 Barley firstboot:     wm_pid = startWindowManager()
Jul 17 11:14:39 Barley firstboot:   File "/usr/sbin/firstboot", line 50, in 
startWindowManager
Jul 17 11:14:39 Barley firstboot:     raise RuntimeError, "Window manager 
failed to start"
Jul 17 11:14:39 Barley firstboot: RuntimeError: Window manager failed to start
Jul 17 11:14:39 Barley rc: Starting firstboot:  failed
Jul 17 11:14:41 Barley kdm[1202]: IO Error in XOpenDisplay
Jul 17 11:14:41 Barley kdm[1187]: Display :0 cannot be opened
Jul 17 11:14:52 Barley kdm[1204]: IO Error in XOpenDisplay
Jul 17 11:14:52 Barley kdm[1187]: Display :0 cannot be opened
Jul 17 11:14:56 Barley kdm[1206]: IO Error in XOpenDisplay
Jul 17 11:14:56 Barley kdm[1187]: Display :0 cannot be opened
Comment 1 Brent Fox 2002-07-17 11:59:00 EDT
Do you have metacity installed?  If not, install it please.  If that fixes the
problem, then this is a bug that's already been fixed.  I forgot to specify
metacity as a dependency for firstboot in the spec file.
Comment 2 Brent Fox 2002-08-12 11:40:20 EDT
Closing since I believe that this bug was caused by metacity not being
installed.  I have since specified a dependency on Metacity in the spec file.

Please reopen if you see this behavior in more recent builds.
Comment 3 Daniel Powell 2002-08-12 12:35:01 EDT
Will do.

Note You need to log in before you can comment on or make changes to this bug.