Bug 690659 - Critical GTK-related error causes Synaptic to crash
Summary: Critical GTK-related error causes Synaptic to crash
Alias: None
Product: Fedora
Classification: Fedora
Component: synaptic
Version: 14
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2011-03-24 23:48 UTC by Brandon
Modified: 2012-08-16 12:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2012-08-16 12:10:07 UTC

Attachments (Terms of Use)

Description Brandon 2011-03-24 23:48:42 UTC
Description of problem:
I tried to launch the Synaptic Package Manager and after I typed in the root password, the user interface will appear for a second and then close. ABRT doesn't prompt me but I ran Synaptic in a shell, and here's what it spit out:

(synaptic:6145): Gtk-CRITICAL **: IA__gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

Looks like a glitch to me.

Version-Release number of selected component (if applicable):
I couldn't launch nor is there a flag I can use in Bash to display the version, but I found a way and according to the Add/Remove Software menu, it's version: 0.57.2-23

How reproducible:
Every time

Steps to Reproduce:
1. Run Synaptic Package Manager
2. Enter root password
3. Program crashes
Actual results:
Program crashes

Expected results:
To run

Additional info:

Comment 1 Fedora End Of Life 2012-08-16 12:10:10 UTC
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 

Note You need to log in before you can comment on or make changes to this bug.