This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 690862 - [abrt] control-center-1:2.91.92-1.fc15: Process /usr/bin/gnome-control-center was killed by signal 11 (SIGSEGV)
[abrt] control-center-1:2.91.92-1.fc15: Process /usr/bin/gnome-control-center...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libmtp (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Linus Walleij
Fedora Extras Quality Assurance
abrt_hash:8f5d9abf60ba5387c3c6c988382...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-25 11:57 EDT by M. A. MacLain
Modified: 2011-12-05 20:36 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-05 13:23:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (25.16 KB, text/plain)
2011-03-25 11:57 EDT, M. A. MacLain
no flags Details

  None (edit)
Description M. A. MacLain 2011-03-25 11:57:41 EDT
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 25759 bytes
cmdline: /usr/bin/gnome-control-center color
comment: See above.
component: control-center
Attached file: coredump, 40308736 bytes
executable: /usr/bin/gnome-control-center
kernel: 2.6.38.1-6.fc15.x86_64
package: control-center-1:2.91.92-1.fc15
rating: 3
reason: Process /usr/bin/gnome-control-center was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Lovelock)
time: 1301068325
uid: 500

How to reproduce
-----
1. Connected Spyder 3 calibrator to USB port.
2. Color applet screen shows blank etries.
3. Can not add device nor perform any function.
Comment 1 M. A. MacLain 2011-03-25 11:57:43 EDT
Created attachment 487588 [details]
File: backtrace
Comment 2 M. A. MacLain 2011-05-13 19:04:53 EDT
Fedora-14 vs Fedora-15 behaviour when connecting the device to the USB port as shown in /var/log/messages.

Fedora-14:
May 10 12:28:54 P5K-2 kernel: [  614.410025] usb 3-1: new full speed USB device using uhci_hcd and address 3 
May 10 12:28:54 P5K-2 kernel: [  614.570223] usb 3-1: New USB device found, idVendor=085c, idProduct=0300 
May 10 12:28:54 P5K-2 kernel: [  614.570229] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0 
May 10 12:28:54 P5K-2 kernel: [  614.570234] usb 3-1: Product: Datacolor Spyder3 
May 10 12:28:54 P5K-2 kernel: [  614.570237] usb 3-1: Manufacturer: ColorVision Inc.
May 10 12:31:06 P5K-2 kernel: [  746.704055] usb 3-1: USB disconnect, address 3


Fedora-15:
May 10 08:01:58 P5K kernel: [ 1698.910054] usb 3-1: new full speed USB device using uhci_hcd and address 3 
May 10 08:01:58 P5K kernel: [ 1699.070854] usb 3-1: New USB device found, idVendor=085c, idProduct=0300 
May 10 08:01:58 P5K kernel: [ 1699.070859] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0 
May 10 08:01:58 P5K kernel: [ 1699.070863] usb 3-1: Product: Datacolor Spyder3 
May 10 08:01:58 P5K kernel: [ 1699.070865] usb 3-1: Manufacturer: ColorVision Inc. 
May 10 08:01:58 P5K mtp-probe: checking bus 3, device 3: "/sys/devices/pci0000:00/0000:00:1a.0/usb3/3-1" 
May 10 08:01:58 P5K mtp-probe: bus: 3, device: 3 was not an MTP device 
May 10 08:01:58 P5K kernel: [ 1699.477063] usb 3-1: USB disconnect, address 3 
May 10 08:01:59 P5K kernel: [ 1699.683023] usb 3-1: new full speed USB device using uhci_hcd and address 4 
May 10 08:01:59 P5K kernel: [ 1699.843766] usb 3-1: New USB device found, idVendor=085c, idProduct=0300 
May 10 08:01:59 P5K kernel: [ 1699.843772] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0 
May 10 08:01:59 P5K kernel: [ 1699.843776] usb 3-1: Product: Datacolor Spyder3 
May 10 08:01:59 P5K kernel: [ 1699.843778] usb 3-1: Manufacturer: ColorVision Inc. 
May 10 08:01:59 P5K mtp-probe: checking bus 3, device 4: "/sys/devices/pci0000:00/0000:00:1a.0/usb3/3-1" 
May 10 08:01:59 P5K mtp-probe: bus: 3, device: 4 was not an MTP device 
May 10 08:01:59 P5K kernel: [ 1700.068123] usb 3-1: USB disconnect, address 4 
May 10 08:01:59 P5K kernel: [ 1700.274022] usb 3-1: new full speed USB device using uhci_hcd and address 5 
May 10 08:01:59 P5K kernel: [ 1700.434686] usb 3-1: New USB device found, idVendor=085c, idProduct=0300 
May 10 08:01:59 P5K kernel: [ 1700.434691] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0 
May 10 08:01:59 P5K kernel: [ 1700.434695] usb 3-1: Product: Datacolor Spyder3 
May 10 08:01:59 P5K kernel: [ 1700.434698] usb 3-1: Manufacturer: ColorVision Inc. 
May 10 08:01:59 P5K mtp-probe: checking bus 3, device 5: "/sys/devices/pci0000:00/0000:00:1a.0/usb3/3-1" 
May 10 08:01:59 P5K mtp-probe: bus: 3, device: 5 was not an MTP device 
May 10 08:01:59 P5K kernel: [ 1700.454092] usb 3-1: USB disconnect, address 5 
May 10 08:02:00 P5K kernel: [ 1701.160020] usb 3-1: new full speed USB device using uhci_hcd and address 6 
May 10 08:02:00 P5K kernel: [ 1701.201725] gnome-control-c[3106]: segfault at 50 ip 00007f9060196ba5 sp 00007fff6fadee40 error 4 in libcolor.so[7f9060186000+3e000] 
May 10 08:02:00 P5K kernel: [ 1701.320564] usb 3-1: New USB device found, idVendor=085c, idProduct=0300 
May 10 08:02:00 P5K kernel: [ 1701.320569] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0 
May 10 08:02:00 P5K kernel: [ 1701.320573] usb 3-1: Product: Datacolor Spyder3 
May 10 08:02:00 P5K kernel: [ 1701.320576] usb 3-1: Manufacturer: ColorVision Inc. 
May 10 08:02:00 P5K mtp-probe: checking bus 3, device 6: "/sys/devices/pci0000:00/0000:00:1a.0/usb3/3-1" 
May 10 08:02:00 P5K mtp-probe: bus: 3, device: 6 was not an MTP device 
May 10 08:02:00 P5K kernel: [ 1701.547059] usb 3-1: USB disconnect, address 6
 
=================================================================
 
NOTE.-
With F-15 the cycling behaviour continues until the device is removed from the usb port.
Comment 3 Zoran Pericic 2011-05-14 18:26:31 EDT
Removing libmtp solve this problem, so problem is in libmtp. It seams that udev think this is a some kind of multimedia player and run mtp-probe.
Comment 4 M. A. MacLain 2011-05-15 10:25:02 EDT
Zoran thanks for your interest and help. 

Did you actually tested removing "libmtp"?

I did not try to remove "libmtp" because in my box the following
29 packages had to also be removed due to dependency issues:

 AcetoneISO, AcetoneISO2,  PyQt4, digikam, digikam-libs,
 hplip-gui, k3b, k3b-common, k3b-extras-freeworld,
 k3b-libs, kdebase, kdebase-libs, kdebase-runtime,
 kdebase-runtime-flags, kdebase-runtime-libs,
 kdeedu-marble, kdeedu-marble-libs,  kdegraphics-libs,
 kdelibs, kdemultimedia-libs, kdenlive, kdepimlibs,
 phonon, phonon-backend-vlc, qt-recordmydesktop,
 qt-webkit, rhythmbox, vlc, vlc-core.

Regards
Comment 5 Zoran Pericic 2011-05-15 10:42:36 EDT
Yes I do and as you noticed many packgaes depand on it so they have to be removed. 

I created ICC profile, but something else is broken in f15. ICC profile is applied but it's not working, no change i color. This sould be investigated but i'am currntly working something else, so I tempoarily manualy setted display.

You could remove all packages, make profile and commit another bug for profile applying.
Comment 6 Fiona Bianchi 2011-07-03 06:05:57 EDT
I had exactly the same issue and it was also solved by removing libmtp (and vlc-core and rhythmbox which depended upon it).  The gnome-control-colour application still crashed on plugging in the Spyder3 but I was able to run dispcal manually to get a profile.
Comment 7 Richard Hughes 2011-11-15 07:37:01 EST
Ressigning to libmpt.
Comment 8 M. A. MacLain 2011-12-03 22:44:37 EST
Please close this bug.  It appears that some update solved the issue, The last calibration attempt was succesful.

Regards,
Comment 9 Linus Walleij 2011-12-05 13:23:56 EST
Yes libmtp 1.1.1 specifically address this issue after fixing a bug report from Debian of the same issue, if it works for you, I'll close it now. Sorry for the inconvenience.
Comment 10 M. A. MacLain 2011-12-05 20:34:17 EST
Thank you.  Yes you may close it.  It is working well.
Comment 11 M. A. MacLain 2011-12-05 20:36:19 EST
Thank you.  Yes you may close it.  It is working well.

Note You need to log in before you can comment on or make changes to this bug.