Bug 69098 - perl.req is not executable
perl.req is not executable
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
: 69146 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-17 16:15 EDT by Florin Andrei
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-18 08:06:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2002-07-17 16:15:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
While rebuilding perl...src.rpm, the dependencies at the end of the rebuild
failed (see errors below). The cause is perl.req which didn't had the x flag set:
[root@stantz root]# ls -l /usr/lib/rpm/perl.req 
-rw-r--r--    1 rpm      rpm          6366 Apr 18 14:35 /usr/lib/rpm/perl.req
I changed that to 755 and i was able to rebuild perl.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rebuild perl from src.rpm
2.
3.
	

Actual Results:  the dependencies checkup fails.

Expected Results:  the dependencies should be determined correctly.

Additional info:

These are the error messages that i got because of perl.req:

Provides: perl(CPAN) perl(CPAN::Author) perl(CPAN::Bundle) perl(CPAN::CacheMgr)
perl(CPAN::Complete) perl(CPAN::Config) perl(CPAN::Debug)
perl(CPAN::Distribution) perl(CPAN::Eval) perl(CPAN::FirstTime) = 1.53
perl(CPAN::FTP) perl(CPAN::FTP::netrc) perl(CPAN::Index) perl(CPAN::InfoObj)
perl(CPAN::LWP::UserAgent) perl(CPAN::Mirrored::By) perl(CPAN::Module)
perl(CPAN::Nox) = 1.00 perl(CPAN::Queue) perl(CPAN::Shell) perl(CPAN::Tarzip)
perl(CPAN::Version)
PreReq: rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <=
3.0.4-1 rpmlib(VersionedDependencies) <= 3.0.3-1
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(VersionedDependencies) <= 3.0.3-1
Requires: perl >= 1:5.6.1-34.72.6SGI
Processing files: perl-CGI-2.752-34.72.6SGI
Finding  Provides: (using /usr/lib/rpm/find-provides)...
Finding  Requires: (using /usr/lib/rpm/find-requires)...
/usr/lib/rpm/find-requires: /usr/lib/rpm/perl.req: /usr/bin/perl: bad
interpreter: Permission denied
Provides: perl(CGI) perl(CGI::Carp) perl(CGI::Cookie) perl(CGI::Fast)
perl(CGI::Pretty) perl(CGI::Push) perl(CGI::Util) = 1.1 perl(Fh)
perl(MultipartBuffer) perl(TempFile)
PreReq: rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <=
3.0.4-1 rpmlib(VersionedDependencies) <= 3.0.3-1
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(VersionedDependencies) <= 3.0.3-1
Requires: perl >= 1:5.6.1-34.72.6SGI
Processing files: perl-DB_File-1.75-34.72.6SGI
Finding  Provides: (using /usr/lib/rpm/find-provides)...
Finding  Requires: (using /usr/lib/rpm/find-requires)...
/usr/lib/rpm/find-requires: /usr/lib/rpm/perl.req: /usr/bin/perl: bad
interpreter: Permission denied
Provides: DB_File.so perl(DB_File) = 1.75 perl(DB_File::BTREEINFO)
perl(DB_File::HASHINFO) perl(DB_File::RECNOINFO)
PreReq: rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <=
3.0.4-1 rpmlib(VersionedDependencies) <= 3.0.3-1
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(VersionedDependencies) <= 3.0.3-1
Requires: perl >= 1:5.6.1-34.72.6SGI ld-linux.so.2 libc.so.6 libdb-3.3.so
libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1.3)
Processing files: perl-NDBM_File-1.75-34.72.6SGI
Finding  Provides: (using /usr/lib/rpm/find-provides)...
Finding  Requires: (using /usr/lib/rpm/find-requires)...
/usr/lib/rpm/find-requires: /usr/lib/rpm/perl.req: /usr/bin/perl: bad
interpreter: Permission denied
Provides: NDBM_File.so perl(NDBM_File)
PreReq: rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <=
3.0.4-1
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
Requires: perl >= 1:5.6.1-34.72.6SGI ld-linux.so.2 libc.so.6 libdb.so.3
libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1.3) libdb.so.3(GLIBC_2.0)
Wrote: /usr/src/redhat/SRPMS/perl-5.6.1-34.72.6SGI.src.rpm
Wrote: /usr/src/redhat/RPMS/i386/perl-5.6.1-34.72.6SGI.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/perl-CPAN-1.59_54-34.72.6SGI.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/perl-CGI-2.752-34.72.6SGI.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/perl-DB_File-1.75-34.72.6SGI.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/perl-NDBM_File-1.75-34.72.6SGI.i386.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.34490
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd perl-5.6.1
+ '[' /var/tmp/perl-root '!=' / ']'
+ rm -rf /var/tmp/perl-root
+ exit 0
Comment 1 Florian Schirmer 2002-07-18 08:06:08 EDT
*** Bug 69146 has been marked as a duplicate of this bug. ***
Comment 2 Jeff Johnson 2002-07-18 09:40:55 EDT
Yup. rpm-4.0.4 (for Red Hat 7.x and previous) ships with
the execute bit off, rpm-4.1 has it on, which means you,
the builder need to figger out whether you want auto-generated
perl requirements or not, and perform the chmod as appropriate.

That's what was asked for. Personally, I'd like to see
a common default configuration, but it's not my call.

Note You need to log in before you can comment on or make changes to this bug.