This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 69102 - menus in kdebase 3.0.2-2 are broken
menus in kdebase 3.0.2-2 are broken
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kdebase (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-17 16:30 EDT by Need Real Name
Modified: 2007-04-18 12:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-21 18:22:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-17 16:30:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
only the desktop files in /usr/share/applnk/ are in the menu. the other dirs which contain *.desktop files are ignored.
it seems that the vfolder kio lib does not work (where can I find infos about vfolder other than reading the source?).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
	

Expected Results:  i want my menus back :)

Additional info:

[root@abc X11]# rpm -V kdebase
.......T c /etc/kderc
The gnome menus work (but i dont like gnome).
Comment 1 Need Real Name 2002-07-17 23:57:31 EDT
 kdebase 3.0.2-3 does not fix this bug 100%. now the files in /etc/X11/applnk 
are loaded but no other...
Comment 2 Ngo Than 2002-07-19 07:00:02 EDT
i have already fixed it in kdebase-3.0.2-4.

Havoc, many gnome applications (Categorie Settings) should not be showed in
Preferences menu if a user runs in KDE desktop enviroment.

I don't think it makes sense to have them here because:
 - they depends on desktop and they don't work or don't work fine
 - KDE already have them and they work perfect here

I have not a complete list of such gnome progs, but there are some of them
i found:
 accessibility-keyboard.desktop@
 background.desktop@
 behavior.desktop@
 default-applications.desktop@
 file-types.desktop@
 font-properties.desktop@
 gnome-gdmphotosetup.desktop@
 gnome-network-preferences.desktop@
 gnome-panel-preferences.desktop@
 gtk-theme-selector.desktop@
 metacity-properties.desktop@
 mouse.desktop@
 screensaver-properties.desktop@
 session-properties.desktop@
 sound.desktop@
 userinfo.desktop@




Comment 3 Havoc Pennington 2002-07-19 10:13:53 EDT
Yes, most of those clearly should be OnlyShowIn=GNOME; with a couple of possible
exceptions. We'll be iteratively cleaning up the menus.
Comment 4 Jay Turner 2002-09-03 12:48:04 EDT
Things look pretty good with kdebase-3.0.3-10.

Note You need to log in before you can comment on or make changes to this bug.