This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 69125 - lm_sensors support for ucd_snmp
lm_sensors support for ucd_snmp
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
: FutureFeature
: 76509 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-17 21:06 EDT by Ben Woodard
Modified: 2015-03-04 20:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-24 16:51:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The original usupported lm_sensors patch (13.04 KB, patch)
2002-07-17 21:07 EDT, Ben Woodard
no flags Details | Diff
The patch that I coded up which dlopens the lm_sensors library (4.19 KB, patch)
2002-07-17 21:09 EDT, Ben Woodard
no flags Details | Diff

  None (edit)
Description Ben Woodard 2002-07-17 21:06:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020606

Description of problem:
The client, LLNL, needs to have lm_sensors support for the ucd_snmp snmpd. A
long time ago RH supplied an unsupported patch which provides this
functionality. They would like to roll this into the main distribution but
lm_sensors is exceedingly dangerous on some systems. Evidently it can burn out a
thinkpad or something like that.

So LLNL had me code up a way that the same binary can be used on a system with
or without lm_sensors. What I did was use dlopen to load the sensors library if
it exists. If not then that part of the mib is never even registered.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.snmpwalk host community host.hrSensors

	

Actual Results:  no sensor readings are listed

Expected Results:  sensor readings are listed

Additional info:

Let me know if I need to make more sophisticated logic for deciding when to use
the lm_sensors functionality.
Comment 1 Ben Woodard 2002-07-17 21:07:58 EDT
Created attachment 65708 [details]
The original usupported lm_sensors patch
Comment 2 Ben Woodard 2002-07-17 21:09:14 EDT
Created attachment 65709 [details]
The patch that I coded up which dlopens the lm_sensors library
Comment 3 Ben Woodard 2002-07-17 21:11:05 EDT
The sensor-dl.patch applies on top of the sensor.patch. The spec file
modifications were extremely minor. I simply added, the patch to the sources
list and to the prep section. The patch applies with -p1.

Comment 4 Ben Woodard 2002-07-17 23:59:12 EDT
James Antill posits that it is weird to have a piece of software change behavior
simply because another package is installed. He suggested adding a configuration
option which would try to enable that functionality. If that functionality is
not available i.e. snmpd cannot load the library or resolve all the symbols then
spit out something to syslog.
Comment 5 Phil Knirsch 2002-08-07 10:55:57 EDT
Errata packages have been done, waiting for QA to pick them up and finalize them.

Read ya, Phil
Comment 6 Phil Knirsch 2003-05-02 06:40:09 EDT
*** Bug 76509 has been marked as a duplicate of this bug. ***
Comment 7 Phil Knirsch 2003-09-24 16:51:39 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2002-159.html

Note You need to log in before you can comment on or make changes to this bug.