Bug 69134 - syslog messages look like they come from the application
Summary: syslog messages look like they come from the application
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcp_wrappers   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-18 04:02 UTC by James Antill
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-22 09:59:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Antill 2002-07-18 04:02:38 UTC
Description of Problem:
 If tcp_wrappers is disabling access to a service then the message in syslog
looks like it is comming from the calling application. When the application
itself also has Access Control measures this usually causes confusion.

Version-Release number of selected component (if applicable):
 All versions.

How Reproducible:
 Always.

Additional Information:
	
 This only needs to be a simple cosmetic change in the syslog message, making it
obvious that the message originated from the libwrap.a code and not the
application itself.

Comment 1 Thomas Woerner 2004-04-21 15:25:42 UTC
Closing wontfix.
The application, which is using tcp_wrappers, should not generate
extra messages.

Comment 2 James Antill 2004-04-21 20:23:57 UTC
Err, what?

Applications like apache, samba, rsyncd and snmpd all have their own
access controls. So what are you saying ... that they should never be
used or that if they fail they should never be logged?


Comment 3 Thomas Woerner 2004-04-22 09:59:12 UTC
The application is not logging (should not log) the same errors or
restrictions as tcp_wrappers does, so there is no conflict. This is
what I tried to say.

By the way: If I modify the log message, then some programs (eg. log
analyzers) have problems with this. It is not useful to make it
incompatible to them.


Note You need to log in before you can comment on or make changes to this bug.