Bug 69147 - META HTTP-refresh Redirects are converted into strange HTML not understand by Netscape4 or Opera6
META HTTP-refresh Redirects are converted into strange HTML not understand by...
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: privoxy (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
http://lists.netsys.com/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-18 06:36 EDT by Peter Bieringer
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-18 06:36:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2002-07-18 06:36:15 EDT
Description of problem:
Browsing to e.g. "http://lists.netsys.com/" will not work because of converting the META HTTP-redirect into strange HTML which isn't understood by 
Netscape4 or Opera6

Version-Release number of selected component (if applicable):
2.9.15-4


How reproducible:
Always

Steps to Reproduce:
1. Browse to URL http://lists.netsys.com through privoxy
	

Actual Results:  # telnet ***** 8118
Trying *****...
Connected to ****
Escape character is '^]'.
GET http://lists.netsys.com/ HTTP/1.0

HTTP/1.1 200 OK
Date: Thu, 18 Jul 2002 10:20:01 GMT
Server: Apache/1.3.26 (Unix)
Last-Modified: Tue, 09 Jul 2002 16:45:33 GMT
ETag: "2af2-79-3d2b132d"
Accept-Ranges: bytes
Content-Length: 104
Content-Type: text/html
Connection: close

<HEAD>
<link rev="x-refresh" href=/mailman/listinfo>
</HEAD>
<body  BGCOLOR="#FFFFFF">
</body>
</html>


Expected Results:  More compatible HTML code, e.g. the original one

# telnet lists.netsys.com 80
Trying 199.201.233.17...
Connected to lists.netsys.com.
Escape character is '^]'.
GET / HTTP/1.0
Host: lists.netsys.com

HTTP/1.1 200 OK
Date: Thu, 18 Jul 2002 10:31:17 GMT
Server: Apache/1.3.26 (Unix)
Last-Modified: Tue, 09 Jul 2002 16:45:33 GMT
ETag: "2af2-79-3d2b132d"
Accept-Ranges: bytes
Content-Length: 121
Connection: close
Content-Type: text/html

<HEAD>
<META HTTP-EQUIV="refresh" CONTENT="0; url=/mailman/listinfo">
</HEAD>
<body  BGCOLOR="#FFFFFF">
</body>
</html>



Additional info:
Comment 1 Karsten Hopp 2002-08-07 08:37:52 EDT
I could get to  http://lists.netsys.com through privoxy-2.9.16-1 without 
any problems. Seems to be fixed upstream. 
Please reopen this report if you still have problems with the latest privoxy  
package from Rawhide.

Note You need to log in before you can comment on or make changes to this bug.