Bug 69156 - Spec file / misc tweaks
Summary: Spec file / misc tweaks
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: spamassassin (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-18 14:16 UTC by Florian Schirmer
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-28 20:09:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch which twaeks the .spec file for rpm generation (2.05 KB, patch)
2002-07-18 14:17 UTC, Florian Schirmer
no flags Details | Diff
Patch which tweaks init script to load options from /etc/sysconfig/spamassassin (578 bytes, patch)
2002-07-18 14:20 UTC, Florian Schirmer
no flags Details | Diff
/etc/sysconfig/spamassassin file (45 bytes, text/plain)
2002-07-18 14:22 UTC, Florian Schirmer
no flags Details
Updated patch (1.06 KB, patch)
2002-09-19 12:09 UTC, Florian Schirmer
no flags Details | Diff

Description Florian Schirmer 2002-07-18 14:16:19 UTC
There are some minor "bugs". Problems fixed by the attached files:

- spamassassin is added/removed using chkconfig
- spamd options are passed by a /etc/sysconfig/spammassassin
  file instead of beeing hardcoded in the init.d startup script
- Some requirements added/fixed

spamd is startet by default. IMHO it should not, but it was default before so i 
did not touch that.

BTW spamassassin isn't availible in rawhide package collection. Maybe someone 
should add it.

Comment 1 Florian Schirmer 2002-07-18 14:17:25 UTC
Created attachment 65785 [details]
Patch which twaeks the .spec file for rpm generation

Comment 2 Florian Schirmer 2002-07-18 14:20:35 UTC
Created attachment 65786 [details]
Patch which tweaks init script to load options from /etc/sysconfig/spamassassin

Comment 3 Florian Schirmer 2002-07-18 14:22:46 UTC
Created attachment 65787 [details]
/etc/sysconfig/spamassassin file

Comment 4 Chip Turner 2002-07-18 21:04:15 UTC
these all look good and have been integrated.  shoukd be in next rawhide.  only
change is not requiring libnet because it was integrated into perl-5.8.0's core.

Comment 5 Florian Schirmer 2002-09-19 12:06:48 UTC
Please replace the init patch by the one attached. It fixes the a path problem 
and checks the return value.

Comment 6 Florian Schirmer 2002-09-19 12:09:26 UTC
Created attachment 76584 [details]
Updated patch


Note You need to log in before you can comment on or make changes to this bug.