Bug 691625 - Admin/Languages: toggle between Enable/Disable is not immediately updated.
Admin/Languages: toggle between Enable/Disable is not immediately updated.
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: hding
Ding-Yi Chen
:
: 693599 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-29 00:00 EDT by Ding-Yi Chen
Modified: 2011-10-28 03:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-28 03:25:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2011-03-29 00:00:57 EDT
Description of problem:
In Administration -> Manage Language, 
when enabling/disabling a language by click the Enable/Disable link,
a confirmation dialog will pop out; however, if you confirm the change,
though the change is actually happen, but the Enable/Disable action still not updated.

That is, if you want to disable language "bem", clicking "Disable" will make "bem" disabled, but the "Disable" action is still visible.


Version-Release number of selected component (if applicable):
Zanata version 1.3-SNAPSHOT (20110329-1034).


How reproducible:
Always

Steps to Reproduce:
1. login as admin
2. Click menu Administration -> Manage Language, 
3. Add language "bem" if it is not in the list.
4. Click "Disable"
5. A confirmation dialog will pops up, click Ok.
  
Actual results:
The available action is "Disable".

Expected results:
The available action should be "Enable".

Additional info:
Comment 1 Sean Flanigan 2011-04-04 23:16:13 EDT
*** Bug 693599 has been marked as a duplicate of this bug. ***
Comment 2 Ding-Yi Chen 2011-07-05 19:39:28 EDT
VERIFIED Zanata version 1.4-SNAPSHOT (20110706-0602).

Note You need to log in before you can comment on or make changes to this bug.