Bug 6919 - rp3 and rp3-config segfault
rp3 and rp3-config segfault
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-11 01:32 EST by ashupp
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-07 07:53:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ashupp 1999-11-11 01:32:21 EST
Upon startup both rp3 and rp3-config crash due to segfault.
I can provide core files if neccesary.  This started
happening immediatly after the upgrade to 6.1 from 5.2.
Both kppp and gnome-ppp work fine.
Comment 1 Michael K. Johnson 1999-11-18 18:43:59 EST
If the errata release rp3-1.0.1 does not fix this for you, please try
ftp://people.redhat.com/johnsonm/rp3/rp3-1.0.2-1.i386.rpm
Comment 2 Michael K. Johnson 1999-12-08 19:53:59 EST
I didn't hear back, but there are a few more bugs fixed in the latest test
release at
ftp://people.redhat.com/johnsonm/rp3/rp3-1.0.3-1.i386.rpm
If I don't hear back by the time I make an official errata release, I'll
assume that one of these two packages has fixed the problem.
Comment 3 ashupp 1999-12-09 01:26:59 EST
Thanks, 1.0.2 fixed the segfaulting.  It now connects fine, but DNS doesn't work
corectly. Fix is trivial, but I suppose I'll open another bug though.
Comment 4 Michael K. Johnson 1999-12-09 16:47:59 EST
Glad to know it is fixed.

Please don't open another bug report unless you have the latest initscripts.
Comment 5 Nalin Dahyabhai 2000-02-04 23:23:59 EST
Which DNS problems were you referring to?  Have they been solved?
Comment 6 ashupp 2000-02-05 20:15:59 EST
Yes, the new initscripts fixed the problem.  The problem was, as far as I could
tell, that /etc/ppp/resolv.conf was being created on connect, but not copied to
/etc/.  If I setup that file by hand, everything worked fine.
Comment 7 Nalin Dahyabhai 2000-02-07 07:53:59 EST
Thanks for following up on this.  I'm tagging this bug as fixed by an errata.

Note You need to log in before you can comment on or make changes to this bug.