Bug 69215 - up2date -p traceback
up2date -p traceback
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-18 22:38 EDT by Michael Schwendt
Modified: 2015-01-07 18:57 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-21 00:23:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2002-07-18 22:38:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020712

Description of problem:
After fully updated Limbo with SSL-fixed rhnlib-0.8-2 from Bugzilla/Rawhide:

# up2date -p 
Adding cert <X509Name object '/C=US/ST=North Carolina/L=Research Triangle
Park/O=Red Hat, Inc./OU=Red Hat Network Services/CN=RHNS Certificate
Authority/Email=rhns@redhat.com'>
Updating package profile...
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 785, in ?
    main()
  File "/usr/sbin/up2date", line 354, in main
    rhnPackageInfo.updatePackageProfile()
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 62, in
updatePackageProfile
    getInstalledPackageList())
NameError: global name 'getInstalledPackageList' is not defined

Version-Release number of selected component (if applicable):
up2date-2.9.13-7.x.9

How reproducible:
Always

Additional info: Want to run up2date -p because one package (mc-4.5.55-10) has
not been updated in my profile at RHN, although it is installed.
Comment 1 Mihai Ibanescu 2002-07-19 11:34:47 EDT
Fixed in CVS.
Comment 2 Michael Schwendt 2002-07-22 17:23:24 EDT
Confirmed working with up2date 2.9.16-7.x.9.

One warning is new, though:

# up2date -p
/usr/share/rhn/up2date_client/up2dateAuth.py:0: SyntaxWarning: name 'loginInfo'
is assigned to before global declaration

If that one is related, please re-open bug report.

Note You need to log in before you can comment on or make changes to this bug.