Bug 692220 - Test lock failover when making NFSv3 servers active/passive HA
Test lock failover when making NFSv3 servers active/passive HA
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
5.6
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Dean Jansa
Cluster QE
: TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-30 13:57 EDT by Perry Myers
Modified: 2012-02-21 01:19 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Do not document.
Story Points: ---
Clone Of:
: 692221 (view as bug list)
Environment:
Last Closed: 2012-02-21 01:19:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2011-03-30 13:57:20 EDT
Description of problem:
rgmanager supports making NFSv3 servers highly available in an active/passive manner when backed by a non-clustered filesystem.  In this configuration scenario, you would want to be able to fail over the locks from one server to another so that the passive node can immediately pick up where the failed server left off.

This lock failover has not been extensively tested in a while, so this bug is to track testing of lock failover specifically.

Notes:

> 1) Add this to /etc/sysconfig/nfs:
> 
>    STATDARG="-H /usr/sbin/clunfslock"
> 
> 2) In cluster.conf, your service _MUST_ be structured like this; if you
> don't get the dependency chains just right, it will not work:
> 
>    ...
>    <resources>
>      <nfsexport name="nfsexports"/>
>    </resources>
>    ...
>    <service name="foo" nfslock="1" ... >
>      <fs name="fs1" ... >
>        <nfsexport ref="nfsexports">
>          <nfsclient ... />
>          <nfsclient ... />
>          ...
>        </nfsexport>
>      </fs>
>      <fs name="fs2" ... >
>        <nfsexport ref="nfsexports">
>          <nfsclient ... />
>          <nfsclient ... />
>          ...
>        </nfsexport>
>      </fs>
>      <ip ... />
>    </service>
Comment 3 Lon Hohberger 2012-01-19 14:19:44 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Do not document.
Comment 4 errata-xmlrpc 2012-02-21 01:19:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0163.html

Note You need to log in before you can comment on or make changes to this bug.