Bug 692700 - missing dependency on globus-gssapi-gsi-devel
Summary: missing dependency on globus-gssapi-gsi-devel
Keywords:
Status: CLOSED DUPLICATE of bug 695344
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: globus-gssapi-error
Version: el5
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Mattias Ellert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-31 21:07 UTC by Dennis van Dok
Modified: 2011-04-25 03:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-25 03:36:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 692678 None None None Never

Internal Links: 692678

Description Dennis van Dok 2011-03-31 21:07:15 UTC
Description of problem:

The file /usr/include/globus/globus_error_gssapi.h from globus-gssapi-error-devel contains

#include "gssapi.h"

This header file is provided by globus-gssapi-gsi-devel, but no dependency is defined in the RPM.

Version-Release number of selected component (if applicable):

2.5-5.el5

How reproducible:

Trivial

Steps to Reproduce:
1. yum install globus-gssapi-gsi-devel
2. rpm -q --requires globus-gssapi-gsi-devel
3. observe missing dependency
  
Actual results:

globus-common-devel >= 3
globus-core >= 4
globus-gss-assist-devel >= 3
globus-gssapi-error = 2.5-5.el5
libglobus_gssapi_error.so.2  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

Expected results:

The above, including

globus-gssapi-gsi-devel

Additional info:

As observed on a CentOS 5 machine.

Comment 1 Mattias Ellert 2011-04-25 03:36:41 UTC

*** This bug has been marked as a duplicate of bug 695344 ***


Note You need to log in before you can comment on or make changes to this bug.