Bug 692730 - /selinux mount device shows as "none"
/selinux mount device shows as "none"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libselinux (Show other bugs)
15
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-31 19:34 EDT by Cesar Eduardo Barros
Modified: 2012-07-27 09:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-27 09:22:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (untested) (1.23 KB, patch)
2011-03-31 19:34 EDT, Cesar Eduardo Barros
no flags Details | Diff

  None (edit)
Description Cesar Eduardo Barros 2011-03-31 19:34:45 EDT
Created attachment 489265 [details]
Proposed patch (untested)

Description of problem:

The mount output for /selinux shows as:

none on /selinux type selinuxfs (rw,relatime)

It would be slightly more readable if it were something like:

selinuxfs on /selinux type selinuxfs (rw,relatime)

/selinux is currently the only one on the mount output to use "none". IIRC, a similar change was made to the mount of /proc many years ago.


Version-Release number of selected component (if applicable):

libselinux-2.0.98-2.fc15.i686

How reproducible:

Always.

Steps to Reproduce:

Boot with selinux enabled.
  
Actual results:

none on /selinux type selinuxfs (rw,relatime)

Expected results:

Something better than "none".

Additional info:
Comment 1 Cesar Eduardo Barros 2011-03-31 19:36:22 EDT
Comment on attachment 489265 [details]
Proposed patch (untested)

Fix attachment details
Comment 2 Daniel Walsh 2012-07-27 09:22:29 EDT
Since this version of Fedora is no longer supported I am closing this bugs.  If you are still seeing this bug in a current version of fedora, please reopen the bugzilla with the appropriate version number.

Note You need to log in before you can comment on or make changes to this bug.