Bug 692775 - HWCert: RedHat v7-1.3-19 network test fails on RHEL6.0 GA with HTTP test during file transfer
HWCert: RedHat v7-1.3-19 network test fails on RHEL6.0 GA with HTTP test duri...
Status: CLOSED DUPLICATE of bug 524983
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.3
All All
unspecified Severity urgent
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-01 01:50 EDT by Akash Kodenkiri
Modified: 2011-04-05 09:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-05 09:35:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Network test output (5.13 KB, application/octet-stream)
2011-04-01 01:50 EDT, Akash Kodenkiri
no flags Details

  None (edit)
Description Akash Kodenkiri 2011-04-01 01:50:14 EDT
Created attachment 489305 [details]
Network test output

Description of problem:  i have used HWCert v7-1.3-19(Beta) test suite for testing on RHEL6 OS. Both Test server and Client installed with Hwcert V7-1.3-19 package and trigger the network test. Network test failed during HTTP file transfer with "response code 403". 

<output name="HTTP" description="HTTP file transfer test">
sending file /var/www/html/httptest.file hash: 66fa256e27c069425c2097aa2e17bd48
Error: could not send message (response code 403)
Message: Forbidden
sending file /var/www/html/httptest.file hash: 0d7e741a026a410360aaede04543c273
Error: could not send message (response code 403)
Message: Forbidden
sending file /var/www/html/httptest.file hash: 1be03569981af27adf152903bbe76914
Error: could not send message (response code 403)
Message: Forbidden
sending file /var/www/html/httptest.file hash: 08ed66ee83bd1f327f2d83edf2529a01
Error: could not send message (response code 403)
Message: Forbidden
Http test had 4 errors
<summary>FAIL</summary>
</output>


Version-Release number of selected component (if applicable):
HWcert V7-1.3-19(Beta) package used on RHEL 6 OS.

How reproducible:
Configure both client and server OS with Hwcert v7-1.3-19 package. Disable firewall on both OS and trigger network test.

Steps to Reproduce:
1. Configure RHEL6 OS with Client and server test suite of HWcert-v7-1.3-19
2. Start Network test
3. wait till the test completes
  
Actual results:
Network test failed during HTTP file transfer test. Actually HTTPD service is in running state on both client server but test fails. i have tried on two different setups(i586 and x86_64) and test got failed on both the setup. Also executed the test with SELinux disable mode.

Expected results:
Network test should pass without any issue. These test got passed with HWCert V7-1.2-16 package, which used nfs for file transfer.

Additional info: Please find attached test log for more details.
Comment 2 Akash Kodenkiri 2011-04-04 23:56:02 EDT
Any updates on this bug ?
Comment 3 Greg Nichols 2011-04-05 09:35:41 EDT
Closing as duplicate of #524983.   The work-around is to disable selinux on the v7 server.

*** This bug has been marked as a duplicate of bug 524983 ***

Note You need to log in before you can comment on or make changes to this bug.