Bug 693310 - Unresolvable dependency python-qpid-qmf in qpid-tools.noarch
Unresolvable dependency python-qpid-qmf in qpid-tools.noarch
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qpid-tools (Show other bugs)
6.1
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Nuno Santos
MRG Quality Engineering
: ZStream
Depends On: 679803
Blocks: 711816
  Show dependency treegraph
 
Reported: 2011-04-04 06:05 EDT by Daniel Mach
Modified: 2013-09-12 18:12 EDT (History)
10 users (show)

See Also:
Fixed In Version: qpid-qmf-0.10-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-23 11:04:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Mach 2011-04-04 06:05:20 EDT
Latest composes are DOOMED due to unresolved dependency in qpid-tools.
python-qpid-qmf is not provided by any package.
Shouldn't the Requires: be python-qmf instead?

It may be coincidence, but the problem always appeared on s390x.
Comment 2 Charlotte Richardson 2011-04-07 11:31:35 EDT
The actual error I get attempting to install RHEL6.1-snap2 is that
qpid-tools-0.7.946105-5.el6.noarch requires python-qmf = 0.7.9461906

Looking at what is in the iso shows:
python-qmf-0.7.946106-6.el6.noarch.rpm
qpid-tools-0.7.946106-5.el6.noarch.rpm

Telling the installation to "continue" seems to result in the system installing and running properly despite the dependency issue.
Comment 7 Nuno Santos 2011-05-31 15:25:21 EDT
Those -0.7 packages are quite old, and should not be in RHEL6 at this point. Please give it a try with the more recent -0.10 rpms (namely qpid-qmf-0.10-7.el6), the issue should have been fixed.
Comment 9 errata-xmlrpc 2011-06-23 11:04:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0893.html

Note You need to log in before you can comment on or make changes to this bug.