Bug 693401 - Eclipse crashing in openjdk at libxul.so
Eclipse crashing in openjdk at libxul.so
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-04 10:49 EDT by Earle Nietzel
Modified: 2011-07-27 07:49 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-04 16:07:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Earle Nietzel 2011-04-04 10:49:01 EDT
Description of problem:
After starting eclipse it crashes

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-53.1.9.6.fc15.i686
xulrunner-2.0-1.fc15.i686
eclipse-jee-helios-SR2-linux-gtk.tar.gz

How reproducible:
Every time

Steps to Reproduce:
1. Install eclipse on F15 
2. After it starts I go to eclipse market place to add new packages and it crashes
  
Additional info:
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x50796e2b, pid=6030, tid=3079423680
#
# JRE version: 6.0_20-b20
# Java VM: OpenJDK Client VM (19.0-b09 mixed mode linux-x86 )
# Derivative: IcedTea6 1.9.6
# Distribution: Fedora release 15 (Rawhide), package fedora-53.1.9.6.fc15-i386
# Problematic frame:
# C  [libxul.so+0xd5be2b]
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Comment 1 Matěj Cepl 2011-04-04 15:10:44 EDT
Cannot reproduce with Fedora 15 Eclipse eclipse-platform-3.6.1-5.fc15.x86_64, and eclipse-mpc-1.0.1-2.fc15.noarch. I was able to find and install a package from Eclipse Marketplace.

Why do you use non-Fedora Eclipse?

Anyway, reassigning to Eclipse.
Comment 2 Earle Nietzel 2011-04-04 15:41:23 EDT
Hello,

When I was using eclipse that came with fedora I could not locate all of the WTP packages that I needed?

Regardless the JVM shouldn't be crashing like that.

Thanks,
Earle
Comment 3 Andrew Overholt 2011-04-04 16:07:05 EDT
Hi,

I'm willing to bet a crash occurred due to an API change in XULRunner between the version upstream's SWT binary was built against and the one in Fedora 15.  The odd thing is that I can't make it crash on F15 x86_64 with a Helios SR2 package.

As for WTP not being around, it's not packaged in Fedora but one can add the Helios update site:

  http://download.eclipse.org/releases/helios/

It's not present due to:

  https://bugs.eclipse.org/bugs/show_bug.cgi?id=249133

Unfortunately we can't support applications that were not installed from the Fedora repository so I'm going to have to close this as an upstream bug.  If you can reliably make it crash, I'm sure the upstream Eclipse developers would be interested in hearing about it:

  https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Platform&component=SWT&version=3.6.2

HTH,

Andrew
Comment 4 Earle Nietzel 2011-04-04 16:21:58 EDT
Hi Andrew,

Thanks for the info, and agree with closing it (I was on F15 i686 with Helios SR2).

I will give installing WTP as you have mentioned a try using fedora eclipse.

I did find this bug already logged on icedtea's bugzilla:

http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=673

Looks like an issue with xulrunner 2.0 as it can't be replicated with 1.9.2

regards,
Earle
Comment 5 Earle Nietzel 2011-04-04 17:26:49 EDT
I was not successful at installing any new software from the WTP eclipse helios software update site.

http://download.eclipse.org/webtools/repository/helios/

I then tried

http://download.eclipse.org/releases/helios/

to no avail eclipse kept showing the same problem:

An error occurred while collecting items to be installed
session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.cvs.source,1.0.500.v20100414
No repository found containing: org.eclipse.update.feature,org.eclipse.cvs.source,1.2.0.v20100427-7B77FKt90GE5h0NCO35T7A01911
No repository found containing: osgi.bundle,org.eclipse.ecf.filetransfer.source,4.0.0.201102081657
No repository found containing: osgi.bundle,org.eclipse.ecf.identity.source,3.1.0.201102081657
No repository found containing: osgi.bundle,org.eclipse.ecf.provider.filetransfer.httpclient.source,4.0.0.201102081657
No repository found containing: osgi.bundle,org.eclipse.ecf.provider.filetransfer.httpclient.ssl.source,1.0.0.201102081657
No repository found containing: osgi.bundle,org.eclipse.ecf.provider.filetransfer.source,3.1.0.201102081657
No repository found containing: osgi.bundle,org.eclipse.ecf.provider.filetransfer.ssl.source,1.0.0.201102081657
No repository found containing: osgi.bundle,org.eclipse.ecf.source,3.1.0.201102081657
No repository found containing: osgi.bundle,org.eclipse.ecf.ssl.source,1.0.100.201102081657
No repository found containing: org.eclipse.update.feature,org.eclipse.equinox.p2.user.ui.source,2.0.1.r361_v20100903-897JF_lFRVaY8GYgZHmQCq5
No repository found containing: osgi.bundle,org.eclipse.help.base.source,3.5.2.r36_r20100816
No repository found containing: org.eclipse.update.feature,org.eclipse.help.source,1.2.0.v20100427-7e7kETFCsz-mFu_PfwL1ht5
No repository found containing: osgi.bundle,org.eclipse.jdt.source,3.6.1.r361_v20100714-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.jdt.source,3.6.1.r361_v20100714-0800-7z8XFUSFLBmsgvVz0z-3vjz095IX
No repository found containing: osgi.bundle,org.eclipse.pde,3.6.1.v20100625_r361
No repository found containing: org.eclipse.update.feature,org.eclipse.pde,3.6.1.r361_v20100727-7b7mFL-FDX-bf3Q-g1cCcoM
No repository found containing: osgi.bundle,org.eclipse.pde.source,3.6.1.v20100625_r361
No repository found containing: org.eclipse.update.feature,org.eclipse.pde.source,3.6.1.r361_v20100727-7b7mFL-FDX-bf3Q-g1cCcoM
No repository found containing: osgi.bundle,org.eclipse.platform.source,3.6.1.r361_v20100714-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.platform.source,3.6.1.r361_v20100909-9pF78H4oFrRqo0j7kHFogDSz-B4nsSP2z-oW
No repository found containing: osgi.bundle,org.eclipse.rcp.source,3.6.0.v20100527-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.rcp.source,3.6.1.r361_v20100827-9oBYFOtFkzKz-ApYk1gu5D_V
No repository found containing: osgi.bundle,org.eclipse.sdk,3.6.1.r361_v20100714-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.sdk,3.6.1.r361_v20100714-0800-7Q7m6D9kQgfkB-G1z-jfPG1WEJOCvC4-z0W7qOFVAvZu8
No repository found containing: osgi.bundle,org.objectweb.asm,3.2.0
Comment 6 Andrew Overholt 2011-04-04 18:56:45 EDT
Thanks for opening another bug, Earle.
Comment 7 Earle Nietzel 2011-04-05 01:01:51 EDT
I was able to get around this problem by adding:

-Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner-2/

in eclipse.ini
Comment 8 smilyface 2011-07-22 08:18:26 EDT
Hello all,

i am new to this bugzilla.

Facing same problem :
---------------------
Eclipse Helios crashes with Fedora 15 KDE

But actually it was working fine..for the past 2-3 weeks.

Now my problem is coming when:
------------------------------
1. i am opening eclipse.

2. It will not get crash if i am not using for a long time..!!

3. Using a java project.

4. Withing 2-3 minutes it will be getting crashed.


I installed some plugins before. But i don't know that whether it made this problem. Because i installed ShellED for editing shell script in eclpse (installed before 2weeks).

I tried
-------
1. Increased memory ( i mean xms , xmx , maxpermsize in eclipse.ini file.)
2. Changed java path from openjdk to jdk
3. Did what he told in :
http://www.korri.net/blog/2011/5/6-how-to-fix-eclipse-helios-crashes-on-fedora-15.html
4. And at last as Earle Nietzel told added:
-Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner-2/


is there any other way..?
Comment 9 Alexander Kurtakov 2011-07-22 08:25:45 EDT
Yes use eclipse from rpm it is fixed to not crash because of xulrunner.
`yum install eclipse`
Comment 10 smilyface 2011-07-27 07:35:49 EDT
oh Alexander,

i need Eclipse-Helios itself. I can not use Fedora-eclipse as my application needs so.

So i need it to be cleared in Helios version itself.
Comment 11 Alexander Kurtakov 2011-07-27 07:49:44 EDT
Well, there is nothing we can do for fixing your downloaded eclipse to work. Please open a bug at Eclipse.org to fix it to work with latest xulrunner.

Note You need to log in before you can comment on or make changes to this bug.