Bug 69356 - Unable to add user to group in redhat-config-user (user manager)
Unable to add user to group in redhat-config-user (user manager)
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-users (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-22 07:05 EDT by Pavel
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 14:18:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel 2002-07-22 07:05:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721

Description of problem:
I'm unable to add user to group with user manager (redhat-config-user). In "user
properties" dialog, "groups" tab and in "group properties" dialog, "Group users"
tab, clicking on checkbox does nothing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open User manager (or run redhat-config-users)
2. Select a user
3. Click properties on the toolbar
4. Select Groups tab
5. Click on any group checkbox

OR 

2. Select a group
3. Click properties on the toolbar
4. Select "Group users" tab
5. Click on any user checkbox
	

Actual Results:  Nothing happens

Expected Results:  Add user to a group and mark the appropriate checkbox.

Additional info:

When clicking on checkbox in group properties, following traceback is printed:
Traceback (most recent call last):
  File "/usr/share/redhat-config-users/groupProperties.py", line 159, in
toggled_item
    iter = self.userStore.get_iter(int(row))
TypeError: GtkTreeModel.get_iter() argument 1 must be tuple, not int

When clicking on checkbox in user properties, following traceback is printed:
Traceback (most recent call last):
  File "/usr/share/redhat-config-users/userProperties.py", line 414, in toggled_item
    iter = self.groupStore.get_iter(int(row))
TypeError: GtkTreeModel.get_iter() argument 1 must be tuple, not int
Comment 1 Tim Waugh 2002-08-19 18:34:57 EDT
Do you still see this with redhat-config-users-1.1-13?  I couldn't reproduce 
the problem with that version.
Comment 2 Daniel Walsh 2002-08-21 14:18:43 EDT
http://www.daa.com.au/pipermail/pygtk/2002-May/002885.html
Indicates this might have been fixed in pygtk.
Comment 3 Brent Fox 2002-08-21 16:29:47 EDT
I am unable to reproduce with 1.1-15.  I suspect that dwalsh is correct here. 
Closing as RAWHIDE.  Try updating to the Null beta if you still see this problem.

Note You need to log in before you can comment on or make changes to this bug.