Bug 69357 - gnome-terminal draws text very slow
gnome-terminal draws text very slow
Status: CLOSED DEFERRED
Product: Red Hat Public Beta
Classification: Retired
Component: vte (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-22 07:53 EDT by Pavel
Modified: 2007-04-18 12:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-14 03:30:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel 2002-07-22 07:53:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721

Description of problem:
gnome-terminal draws text significatnly slower then other terminals (xterm,
xterm3d, konsole, gnome-terminal from gnome 1.4). For example displaying of a
file of ~1400 lines (using "cat file") takes 14 seconds with gnome-terminal,
while with xterm it takes only 1.5 seconds and about 2 seconds with konsole.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run gnome terminal
2. display a big text file using cat command or perform any other command that
produces a lot of output or try to configure linux kernel with "make menuconfig"
3. do the same with other teminal program


	

Actual Results:  gnome terminal works much slower

Expected Results:  work faster

Additional info:

BTW: gnome-terminal 1.4 on RedHat 7.3 runs faster than any other terminals I tried.
Comment 1 Nalin Dahyabhai 2002-07-22 11:11:46 EDT
Which X server are you using?  Does it support the RENDER extension?  Please
check this by running 'xdpyinfo' and checking for the list of extensions.  Are
you running on a remote display?  Is the server accelerated at all?
Comment 2 Pavel 2002-07-22 12:01:06 EDT
I tried both local and remote server, all have RENDER extension. Local server is
the default supplied with the distro, with driver for ATI Rage IIC (ati). Remote
server is XFree86 4.2.0 for Cygwin and the default supplied with RedHat 7.3 (ati
driver). I don't know if any of them accelerated. I don't think it's a X server
issue at all, because ALL other terminals work much (up to 10 times) faster and
because it used to work faster with gnome-terminal 1.4 with same (remote) X server.
Comment 3 Jens Petersen 2002-07-31 04:21:17 EDT
I am afraid I have to agree that vte still seems to be significantly slower than
other well-known X terminals.
Comment 4 Nalin Dahyabhai 2002-08-14 03:30:28 EDT
The terminal (as of around 0.7.0 or so) should be noticeably faster due to
reworking of the drawing routines.
Comment 5 Jay Turner 2002-08-16 00:00:56 EDT
I'm still seeing some significant differences in the amount of time that it
takes to display stuff in gnome-terminal versus xterm.  Case in point.  Running
'cat /etc/termcap' in a gnome-terminal takes approximately 9 second.  Doing the
same in an xterm takes about 3.5 seconds.  Guess this is as good as it is going
to get for this release.
Comment 6 will smith 2004-08-04 15:22:09 EDT
On FC2, gnome-terminal was causing far too much X CPU usage for me
(unaccelerated graphics card because the nvidia driver causes me
problems).

I switched to 'xterm -j -s' which does jumpscrolling, i.e. if xterm
does not try to refresh for every line if it gets 'behind'.  Now my
compiling is much faster, and low X CPU activity.

Ideally gnome-terminal should have similar kind of 'jump scrolling'.
Comment 7 Luis P Caamano 2005-02-02 16:51:58 EST
On FC3 no special configuration, running "time cat /etc/termcap" on a 
gnome-terminal takes 11s on my system.  The same thing on an xterm 
takes 2.2s.

Running a vncviewer on my windows xp laptop connected via a 4000/350 
cable connection to a RedHat 9 server at the office, no RENDER 
support, gnome-terminal takes 19.5s and xterm takes 7.7s.

I was using gnome-terminal exclusive but after several months I just 
couldn't stand sometimes waiting 3-8 seconds for gnome-terminal to 
display the ouput of a 'pwd' command.

The vte emulator would always be slower than xterm but does it have 
to that slower?

Originally I thought that maybe RENDER support would make it fast and 
thus, I tried using xf4vnc but that simply produced an even slower 
gnome-terminal.

I gave up and I'm now using xterms, which is not nice because I 
really liked the gnome-terminal tabs and other cool configuration 
features and profiles.

Any chance this problem would get any attention?


Note You need to log in before you can comment on or make changes to this bug.