Bug 69358 - initscripts-6.87-1: errors loading USB modules
initscripts-6.87-1: errors loading USB modules
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-22 08:36 EDT by Jonathan Kamens
Modified: 2014-03-16 22:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-26 09:18:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-07-22 08:36:40 EDT
When I rebooted with initscripts-2.87-1, I got a bunch of errors when it tried
to load the USB modules.  Some of the errors concerned the fact that it couldn't
modify the ksymoops directory because / was still mounted read-only (I
understand why these errors occur, although I wish there was a way to make them
stop).  Others claims that a module named "hid" already existed; I found this odd.
Comment 1 Bill Nottingham 2002-07-22 11:20:34 EDT
Do you have root-on-USB?
Comment 2 Jonathan Kamens 2002-07-22 11:25:43 EDT
I don't know what "root-on-USB" means, so the answer is probably no.
Comment 3 Bill Nottingham 2002-07-22 13:15:33 EDT
What USB devices do you have attached, if any?
Comment 4 Jonathan Kamens 2002-07-22 13:36:32 EDT
Just an APC UPS.
Comment 5 Bill Nottingham 2002-08-13 16:55:43 EDT
I'm presuming this persists? (This still seems odd to me.)

What version of modutils do you have installed?
Comment 6 Jonathan Kamens 2002-08-15 22:12:36 EDT
This persists with modutils-2.4.18-1.
Comment 7 Bill Nottingham 2002-08-15 22:38:20 EDT
Can you post the exact error log? They should be in /var/log/messages.
Comment 8 Jonathan Kamens 2002-08-15 22:41:28 EDT
Aug 15 22:04:32 jik modprobe: modprobe: cannot create
/var/log/ksymoops/20020815.log Read-only file system 
Aug 15 22:04:32 jik modprobe: insmod: a module named hid already exists 
Aug 15 22:04:32 jik modprobe: insmod: cannot create
/var/log/ksymoops/20020815220431.ksyms Read-only file system 
Aug 15 22:04:32 jik modprobe: insmod: insmod
/lib/modules/2.4.19-rc1-ac2/kernel/drivers/usb/hid.o failed 
Aug 15 22:04:32 jik modprobe: insmod: insmod hid failed 
Aug 15 22:04:32 jik modprobe: insmod: cannot create
/var/log/ksymoops/20020815.log Read-only file system 
Aug 15 22:04:32 jik rc.sysinit: Initializing USB HID interface:  failed 
Comment 9 Jonathan Kamens 2002-08-26 09:18:37 EDT
This appears to be gone in current Raw Hide.  Go figure.
Comment 10 Bill Nottingham 2002-08-26 14:20:21 EDT
OK, since I could never reproduce this here, I'll mark this closed.

Note You need to log in before you can comment on or make changes to this bug.