Bug 693607 - There is no available locales in the selection list when creating a project.
There is no available locales in the selection list when creating a project.
Status: CLOSED NOTABUG
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.3-alpha-1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: zanata-dev-internal
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-05 00:37 EDT by Kenichi Takemura
Modified: 2014-08-04 18:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-11 01:09:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenichi Takemura 2011-04-05 00:37:18 EDT
Description of problem:

When creating a new project there is a option to add a customized list of locales. Selecting so, but There is no available locales in the selection list. I have defined 5 languages in manage languages.
    
Version-Release number of selected component (if applicable):

1.3-plpha-1
    
How reproducible:

Always
    
Steps to Reproduce:

1. Login Zanata using admin account.
2. Click menu Project and click Create project
3. Select 'Would you like add a customized list of locales?'
    
Actual results:

There is not available locales.
    
Expected results:

My expectation is enable languages are listed in available locales.
    
Additional info:

No.
Comment 1 Sean Flanigan 2011-04-05 02:43:17 EDT
All the enabled languages appear on the right hand side, because they are pre-selected.  If you remove them from "Selected Locales", they will move to "Available Locales".  "Available Locales" really means "Available but unselected Locales".  

I think it's a pretty common UI convention.  It has the advantage that you can double-click on entries, and they keep moving to the other side so that you can double-click on the next entry.
Comment 2 Ding-Yi Chen 2011-08-11 01:09:16 EDT
Kenichi,

As in Zanata version 1.4-SNAPSHOT (20110811-0602)
The labels are change to "Disabled" and "Enabled" to avoid confusion.

By default, all globally enabled locale (i.e. enabled in Adminstration-> Manage Languages" are also enabled in individual projects.

Note You need to log in before you can comment on or make changes to this bug.