Bug 69379 - not closing <A NAME="foo"> tags
not closing <A NAME="foo"> tags
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: docbook-style-dsssl (Show other bugs)
limbo
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-22 11:35 EDT by Tammy Fox
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-30 18:58:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample SGML file (1.18 KB, text/plain)
2002-07-22 11:35 EDT, Tammy Fox
no flags Details
HTML output from example (1.28 KB, text/plain)
2002-07-22 11:37 EDT, Tammy Fox
no flags Details
docbook-dsssl-1.76-aname.patch (19.82 KB, patch)
2002-07-26 09:52 EDT, Tim Waugh
no flags Details | Diff

  None (edit)
Description Tammy Fox 2002-07-22 11:35:13 EDT
When links are created with <A NAME="foo">, they are not
being closed with </A>. For some reason, Mozilla doesn't 
like this in conjunction with variablelists, and the 
listitems in embedded variablelists are not properly indented.
Adding the </A> formats everything correctly. This only
appears in Mozilla for Linux and Windows. Konqueror, Netscape,
and IE figure out how to parse it correctly. Because
Mozilla does this, it makes some pages incorrectly formated.

Attached is an example SGML file and the HTML output you
can view in Mozilla.
Comment 1 Tammy Fox 2002-07-22 11:35:44 EDT
Created attachment 66285 [details]
Sample SGML file
Comment 2 Tammy Fox 2002-07-22 11:37:21 EDT
Created attachment 66286 [details]
HTML output from example
Comment 3 Tim Waugh 2002-07-22 12:10:42 EDT
I see this.  
  
(FWIW, the XML stylesheets do the right thing.) 
 
Guessing for the moment that it's a DSSSL stylesheet problem rather than an 
openjade one.
Comment 4 Tim Waugh 2002-07-26 09:52:19 EDT
Does this patch help?
Comment 5 Tim Waugh 2002-07-26 09:52:58 EDT
Created attachment 67204 [details]
docbook-dsssl-1.76-aname.patch
Comment 7 Tim Waugh 2002-07-26 10:20:00 EDT
(I've built a package containing this patch and put it here: 
~twaugh/tmp/docbook-style-dsssl-1.76-6.noarch.rpm.  Let me know if it works or 
not.)
Comment 8 Tammy Fox 2002-07-29 09:59:58 EDT
Yes. The attached version looks like it works to me. Thanks!
Comment 9 Tim Waugh 2002-07-30 18:58:07 EDT
Patch applied in docbook-style-dsssl-1.76-6.
Comment 10 Jay Turner 2002-08-29 08:21:18 EDT
Closing this out as it appears to be fixed.
Comment 11 David Lawrence 2006-04-24 15:23:59 EDT
Adding to blocker bug 185483 and also adding IBM confidential group.
Comment 12 David Lawrence 2006-04-24 15:42:30 EDT
Oops. I am sorry for these changes. I searched on the wrong bug list and
mistakenly made these changes. Removing from blocker bug 185483 and also
removing IBM confidential group.

Note You need to log in before you can comment on or make changes to this bug.