Bug 693943 - libpcap-1.1.1-1.fc14: pcap_findalldevs: SIOCGIFFLAGS: bonding_masters: No such device
Summary: libpcap-1.1.1-1.fc14: pcap_findalldevs: SIOCGIFFLAGS: bonding_masters: No suc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libpcap
Version: 14
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 694755 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-06 02:54 UTC by Greg
Modified: 2011-07-06 21:37 UTC (History)
3 users (show)

Fixed In Version: libpcap-1.1.1-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-03 04:48:48 UTC


Attachments (Terms of Use)
Patch from http://bugs.gentoo.org/attachment.cgi?id=234855 (422 bytes, application/octet-stream)
2011-04-06 02:54 UTC, Greg
no flags Details
The same package built for Fedora 14 (current) (237.48 KB, application/x-rpm)
2011-04-23 21:17 UTC, Greg
no flags Details

Description Greg 2011-04-06 02:54:55 UTC
Created attachment 490121 [details]
Patch from http://bugs.gentoo.org/attachment.cgi?id=234855

Description of problem:

The file /sys/class/net/bonding_masters gets in the way when libpcap enumerates the list of network devices.

Version-Release number of selected component (if applicable):

libpcap-1.1.1

How reproducible:

Every time on a host with a bond interface with a kernel that has the file '/sys/class/net/bonding_masters'

Steps to Reproduce:
1. Run jnettop of a machine with a bond interface
  
Actual results:

jnettop exits with the message 'pcap_findalldevs: SIOCGIFFLAGS: bonding_masters: No such device'

Expected results:

jnettop uses the default or selected network device.

Additional info:

Patch is here http://bugs.gentoo.org/attachment.cgi?id=234855
http://sourceforge.net/tracker/index.php?func=detail&aid=2993250&group_id=53067&atid=469579
http://bugs.gentoo.org/323425

Comment 1 Miroslav Lichvar 2011-04-22 09:47:54 UTC
*** Bug 694755 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2011-04-22 11:09:51 UTC
libpcap-1.1.1-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libpcap-1.1.1-3.fc15

Comment 3 Fedora Update System 2011-04-23 01:15:41 UTC
Package libpcap-1.1.1-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libpcap-1.1.1-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/libpcap-1.1.1-3.fc15
then log in and leave karma (feedback).

Comment 4 Greg 2011-04-23 21:17:40 UTC
Created attachment 494459 [details]
The same package built for Fedora 14 (current)

This RPM built for Fedora 14 fixes the issue, and jnettop runs without failing. Thank you.

Comment 5 Fedora Update System 2011-05-03 04:48:43 UTC
libpcap-1.1.1-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Ferry Huberts 2011-05-03 07:41:37 UTC
please also update f14

Comment 7 Fedora Update System 2011-05-03 08:01:42 UTC
libpcap-1.1.1-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libpcap-1.1.1-3.fc14

Comment 8 Ferry Huberts 2011-05-03 09:33:21 UTC
works for me on F14 x86_64 with bonding interface

Comment 9 Fedora Update System 2011-07-06 21:37:21 UTC
libpcap-1.1.1-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.