Bug 694590 - yum online upgrade f14 (up2date) --> f15 devel 2011-04-07 does not work
yum online upgrade f14 (up2date) --> f15 devel 2011-04-07 does not work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i686 Linux
unspecified Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-07 13:48 EDT by shrek-m
Modified: 2014-01-21 18:17 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-07 15:00:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
yum online upgrade f14-f15-devel - errors and packages (12.22 KB, text/plain)
2011-04-07 13:48 EDT, shrek-m
no flags Details

  None (edit)
Description shrek-m 2011-04-07 13:48:11 EDT
Created attachment 490600 [details]
yum online upgrade f14-f15-devel - errors and packages

Description of problem:
yum online upgrade f14 (up2date) --> f15 devel 2011-04-07 does not work
problem-packages, see under additional info.

Version-Release number of selected component (if applicable):
yum-3.2.29-4.fc15.noarch.rpm


How reproducible:
always


Steps to Reproduce:
1. # yum update (f14)
2. # mkdir f15-dev
3. # cd f15-dev
4. downlaod yum* fedora-release*
5. # yum clean all
6. # rpm -Uvh fedora-release-*
7. # rpm -Uvh yum-3*
8. # yum --skip-broken
9. # yum update

  
Actual results:
yum update  /does not work
yum update --skip-broken  /does not work

Expected results:
`yum update` should work
at least `yum update --skip-broken`


Additional info:
---------
# rpm -e gtk-sharp
# yum remove mono*
  - mono-addins
  - mono-core
  - mono-data
  - mono-data-sqlite
  - mono-devel
  - mono-extras
  - mono-ndoc
  - mono-nunit
  - mono-nunit22
  - mono-sharpcvslib
  - mono-wcf
  - mono-web
  - mono-winforms
  - mono-zeroconf
  - monodoc
  - avahi-sharp
  - banshee
  - banshee-musicbrainz
  - beagle
  - beagle-gnome
  - boo
  - evolution-sharp
  - f-spot
  - f-spot-screensaver
  - flickrnet
  - gdata-sharp
  - gio-sharp
  - gkeyfile-sharp
  - gmime-sharp
  - gnome-desktop-sharp
  - gsf-sharp
  - gtk-sharp2
  - libgpod-sharp
  - log4net
  - muine
  - nant
  - ndesk-dbus
  - ndesk-dbus-glib
  - notify-sharp
  - podsleuth
  - taglib-sharp
  - tomboy
  - webkit-sharp

# yum remove openbios*
  - qemu
  - qemu-launcher
  - sytem-ppc
# yum remove gnome-pilot
  - gnome-pilot-conduits
  - gnome-pilot-eds
# yum remove gnome-applet*
  - gnome-applets
  - gnome-applet-vm
# yum remove gnome-netstatus
# yum remove gnome-python2-applet
# yum remove libgail-gnome
# yum remove tsclient 
----------

# yum update
Install 164 Packages
Upgrade 1894 Packages
DownloadSize 1.6 G
Comment 1 James Antill 2011-04-07 15:00:41 EDT
 This isn't a yum bug, it's a whole bunch of packaging bugs in F15 packaging. Probably a bunch of missing obsoletes, if you run with LANG=en_US.utf-8 ... and just paste each of the warnings into bugs for their components, they should get resolved.
Comment 2 shrek-m 2011-04-08 09:31:37 EDT
thanks,
I can not reproduce it with LANG=C because i have removed all problem-packages.

3 translations:
Abhaengigkeitsaufloesung beendet
= Dependencies Resolved
Fehler = Error
Entfernen = Remove


i will try it step by step.
at first, the most dependencies are related to mono* and one to openbios*

mono* bug #694787
openbios* bug #694802



evtl. todo later:
tsclient
---
gnome-pilot
---
gnome-applet*
gnome-python2-applet
gnome-netstatus
libgail-gnome

Note You need to log in before you can comment on or make changes to this bug.