Bug 69472 - default_icon error on GnomeApp
default_icon error on GnomeApp
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: pygtk2 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
: 67888 (view as bug list)
Depends On:
Blocks: 67218 67888 79578 79579
  Show dependency treegraph
 
Reported: 2002-07-22 15:06 EDT by Daniel Walsh
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-07 08:53:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2002-07-22 15:06:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020607

Description of problem:
(redhat-config-services:8393): GLib-GObject-WARNING **: gobject.c:918: object
class `GnomeProgram' has no property named `default-icon'

Is displayed on all GnomeApps.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run glade-2
2.create a GnomeApp
3.Save the Application
Write a python script like the following
import signal
import sys
import gtk
import gnome
import gnome.ui
gnome.program_init("redhat-config-services", "0.1")
import gtk.glade
import os
import string
xml = gtk.glade.XML("/tmp/project1.glade", None, domain="abcd")

Run the script.

Actual Results:  (redhat-config-services:8393): GLib-GObject-WARNING **:
gobject.c:918: object class `GnomeProgram' has no property named `default-icon'

Expected Results:  No error message

Additional info:
Comment 1 Preston Brown 2002-08-21 12:47:07 EDT
*** Bug 67888 has been marked as a duplicate of this bug. ***
Comment 2 Matt Wilson 2003-02-03 17:51:42 EST
fixed in newer gnome-python.
Comment 3 Jay Turner 2003-02-07 08:53:51 EST
No longer seeing this issue with gnome-python2-1.99.14-3.

Note You need to log in before you can comment on or make changes to this bug.