Bug 694802 - Have qemu obsolete openbios-* to fix f14->f16 upgrade issues
Have qemu obsolete openbios-* to fix f14->f16 upgrade issues
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
16
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-08 09:19 EDT by shrek-m
Modified: 2013-01-09 18:46 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 18:59:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shrek-m 2011-04-08 09:19:18 EDT
Description of problem:
openbios* dependencies are blocking a yum distupgrade from f14 (up2date) to
15-devel 2011-04-07
see bug #694590
see attachment https://bugzilla.redhat.com/attachment.cgi?id=490600


--snip---
Error: Package: openbios-ppc-1.0-2.fc12.noarch (@fedora/12)
            Requires: openbios-common = 1.0-2.fc12
            Remove: openbios-common-1.0-2.fc12.noarch (@fedora/12)
                openbios-common = 1.0-2.fc12
            Updated By: openbios-common-1.0-3.fc15.noarch (fedora)
                openbios-common = 1.0-3.fc15
[...]
# yum remove openbios*
  - qemu
  - qemu-launcher
  - sytem-ppc
--snap--


Additional info:
see bug #694590
see attachment https://bugzilla.redhat.com/attachment.cgi?id=490600
Comment 1 Justin M. Forbes 2011-04-18 13:27:11 EDT
This has been fixed with current F15 qemu which no longer has any dependencies on openbios.  The openbios package has been retired.
Comment 2 David Juran 2011-11-27 05:07:39 EST
Re-opening this bug since openbios doesn't seem to be all that retired. Or at least it's still there in F16 with version 1.0-4.1031
openbios-ppc-1.0-2 from F14 however requires openbios-common ov the same release and there is nothing obsoleting or providing openbios-ppc and this breaks the upgrade path.
Comment 4 Cole Robinson 2012-05-29 10:22:19 EDT
Hmm, kinda confused by this myself. The package is retired so we can't easily build a new one to fix the upgrade issues. And not sure why openbios-common is even in the F16 repos.

notting, any suggestion here or are we just stuck with the upgrade issues?
Comment 5 Bill Nottingham 2012-05-29 12:17:26 EDT
Something could obsolete openbios-*. Unsure why it would be in F-16, unless it just didn't get retired until F16 went out.
Comment 6 Cole Robinson 2012-05-29 18:36:36 EDT
I guess we can have qemu obsolete openbios in F16+. If openbios package is ever revived we just need to drop that bit. Moving to qemu
Comment 7 Paolo Bonzini 2012-05-31 11:22:27 EDT
Yeah, I agree.  Cole, can you look into getting an exception from FeSCo for the QEMU binary blobs (at least those that are not for x86, and in particular SLOF and OpenBIOS)?
Comment 8 Fedora Update System 2012-07-30 07:25:19 EDT
qemu-1.0.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/qemu-1.0.1-1.fc17
Comment 9 Fedora Update System 2012-07-30 18:28:53 EDT
Package qemu-1.0.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-1.0.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11302/qemu-1.0.1-1.fc17
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-08-01 14:47:14 EDT
qemu-0.15.1-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-11305/qemu-0.15.1-7.fc16
Comment 11 Fedora Update System 2012-08-01 14:50:50 EDT
qemu-0.15.1-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-11305/qemu-0.15.1-7.fc16
Comment 12 Fedora Update System 2012-08-09 18:59:43 EDT
qemu-0.15.1-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2012-08-09 19:01:52 EDT
qemu-1.0.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.