Bug 69502 - desktop file fixes
desktop file fixes
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: xscreensaver (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-22 16:55 EDT by Havoc Pennington
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-31 15:36:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2002-07-22 16:55:14 EDT
The Categories entry is "Application" with no "s" on the end

Also need X-Red-Hat-Base in here

Need OnlyShowIn=GNOME; until/unless KDE uses it

Comment should be something like "Change screensaver properties"
Comment 1 Jamie Zawinski 2002-07-27 03:27:24 EDT
The screensaver-properties.desktop.in I have in 4.05 contains

    Type=Application
    Categories=Applications;Settings;

Are you saying that it should be

    Type=Applications
    Categories=Applications;Settings;
    OnlyShowIn=GNOME

instead?

(I don't know how any of this stuff works, so you need to use small words with me.)
Comment 2 Havoc Pennington 2002-07-27 12:08:54 EDT
Part of this bug will apply upstream, and part will be a Red Hat specific patch.

Breaking it down:

 - in a Red Hat patch, we should add X-Red-Hat-Base to the Categories line
 - upstream, in Categories, the category is "Application" rather than 
   "Applications" (Type field is correct as-is)
 - upstream, the Comment might be better as perhaps "Change screensaver 
   properties" (others may have better suggestions)
 - arguably upstream, but definitely in RH, 
   the line "OnlyShowIn=GNOME;" should be in there; this will make it appear 
   only in GNOME menus, not in KDE menus (since they are using their own 
   screensaver fork thing). Problem with doing this upstream is that 
   maybe XFCE uses xscreensaver too, and while we can say Red Hat 
   has no XFCE, maybe that doesn't make sense for upstream.
Comment 3 Bill Nottingham 2002-08-12 22:34:20 EDT
Fixed for RH for 4.05-4.
Comment 4 Ray Strode [halfline] 2005-05-12 11:49:50 EDT
Hi,
I'm going through bugs assigned to me and attempting to clean some of the older,
fixed ones up.

This bug hasn't changed in over a year old now.  Are you still seeing the problem? 

(This a batch message is being sent to all my bugs that haven't changed in a year)
Comment 5 Ray Strode [halfline] 2005-05-31 15:36:23 EDT
Hi,

This bug has been in the NEEDINFO state for at least a couple of weeks now.  I'm
going to close the bug, but if you can provide the required information feel
free to open a new report.

Thanks.

(This is a mass message being sent to a bunch of bug reports)

Note You need to log in before you can comment on or make changes to this bug.