Bug 69527 - desktp file fixes
Summary: desktp file fixes
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-22 23:50 UTC by Havoc Pennington
Modified: 2015-01-07 23:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-27 00:07:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Havoc Pennington 2002-07-22 23:50:41 UTC
See also the "desktop file fixes" bug about rhn_register

Most likely X-Red-Hat-Base should just have one icon that combines
register/update  (register first time, then update) and one for the config. If
re-registration is required maybe require command line for that, or have a
button in the up2date GUI.

Anyhow, so for up2date.desktop:
 should just be Name=Update Agent or better something descriptive like
Name=Update Software or Name=Red Hat Network
 
 Needs Categories=X-Red-Hat-Base;System;Application;

 Needs to be in /usr/share/applications and namespaced redhat-up2date.desktop

 Comment should be something like "Get software updates from Red Hat Network"

up2date-config.desktop:
 Name might be just "Red Hat Network" depending on how the rhn_register thing 
 is sorted out. I dunno, this is really hard to name properly, I suspect because 
 the config for up2date should be in up2date, the way every other app works. ;-)

 Comment should just be "Configure settings for Red Hat Network" drop the 
 "allows you to" part and no real need to specify "system and network" settings.

 Should again have X-Red-Hat-Base;System;Application; and move to
/usr/share/applications and namespace the file.

Anyhow, think about these three menu items as a whole; really there should be 
one tool under the System Tools menu that says Red Hat Network, so just one
.desktop file, probably. I'd say the register and configure things are just
things that come up from the single tool.

Remember to get Garrett to fix the lightbulb ;-)

Comment 1 Adrian Likins 2002-07-23 02:02:16 UTC
basically all these changes have been made. 
With the exception of up2date/up2date-config. up2date-config
is just a symlink to up2date and does the same as "up2date --configure".

Not sure the original reason for a seperate desktop file, aside from
it not being obvious how to configure up2date. Part of that is no
doubt because of it's wizard style setup. 

I dont want to bother people by asking them for much config info on
first start up (or worse, every startup) since 90% can leave the
defaults the same (the other 10% are http proxy users, and I currently
pop up a minimal config dialog asking for proxy info on first run for that).

So I dont really know if there should be a seperate desktop or not. I'd 
rather not have one, but without it, it's fairly unobvious how to
configure up2date (but then, most folks shouldnt need to)

Comment 2 Adrian Likins 2002-08-09 02:48:05 UTC
I think the current ones should do...

Comment 3 Todd Warner 2004-08-27 00:07:30 UTC
2 years old. fixed. closing.


Note You need to log in before you can comment on or make changes to this bug.