Bug 69541 - desktop file fixes
desktop file fixes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: xchat (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Reed
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-22 21:23 EDT by Havoc Pennington
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-06 12:59:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2002-07-22 21:23:06 EDT
Should be in X-Red-Hat-Extra;Application;Internet;

move to /usr/share/applications

Namespace net-xchat.desktop
Comment 1 Mike A. Harris 2002-08-04 13:39:59 EDT
Desktop file renamed to net-xchat.desktop, moved
into /usr/share/applications, and Categories entry has been added.

[Desktop Entry]
Name=X-Chat
Comment=IRC Client
Comment[de]=IRC-Client
Comment[es]=Aplicacisn de IRC
Comment[fi]=IRC-sovellus
Comment[fr]=Client IRC
Comment[ko]=IRC E,6s@L>pF.
Comment[no]=IRC-klient
Comment[pt_BR]=Cliente de IRC
Comment[sl]=Odjemalec IRC
Comment[sv]=IRC-klient
Comment[uk]=kL&$NT IRC
Comment[ro]=Client de IRC
Comment[zh_TW]=IRC %N$a:]5{&!
Exec=xchat
Icon=xchat.png
Terminal=0
Type=Application
Categories=X-Red-Hat-Extra;Application;Internet;


New desktop menu file is in rawhide xchat 1.8.9-8

It validates with the validation tool, so I'm assuming all is well.
I'm sure it is correct, however please confirm if it is correct as
this is my first time using the new desktop stuff.
Comment 2 Havoc Pennington 2002-08-04 13:50:03 EDT
You're missing the Encoding key, desktop-file-install will auto-add that for you.
Not a high priority bug because both gnome and kde will try to autodetect
encoding, but should fix sometime.

If I install 1.8.9-8, I don't have a Categories line in the .desktop file, 
apparently?
Comment 3 Mike A. Harris 2002-11-13 03:23:23 EST
This is currently:

[Desktop Entry]
Encoding=UTF-8
Name=IRC Client
Name[de]=IRC-Client
Name[es]=Aplicacisn de IRC
Name[fi]=IRC-sovellus
Name[fr]=Client IRC
Name[ko]=IRC E,6s@L>pF.
Name[no]=IRC-klient
Name[pt_BR]=Cliente de IRC
Name[sl]=Odjemalec IRC
Name[sv]=IRC-klient
Name[uk]=kL&$NT IRC
Name[ro]=Client de IRC
Name[zh_TW]=IRC %N$a:]5{&!
GenericName=IRC Client
Comment=X-Chat
Exec=xchat
Icon=xchat.png
Terminal=false
Type=Application
Categories=X-Red-Hat-Extra;Application;Network;

I'm not sure if there is a problem here or not. I don't know
.desktop files very well, nor know the official documentation URL
that documents these details.  I'm assuming this is all fixed for
now, and trying to get confirmation from others.

Setting to MODIFIED state for testing of xchat-1.8.10-9
Comment 4 Daniel Reed 2004-11-06 12:59:00 EST
xchat's desktop file is currently /usr/share/applications/xchat.desktop .

Its contents are:
[Desktop Entry]
Encoding=UTF-8
Name=IRC
#GenericName=IRC
Comment=X-Chat
Exec=xchat
Icon=xchat.png
Terminal=false
Type=Application
Categories=X-Red-Hat-Extra;Application;Network;

Please reopen if any of this is incorrect.

Note You need to log in before you can comment on or make changes to this bug.