Bug 69570 - Internal compiler error in generate_bytecode_conditional
Internal compiler error in generate_bytecode_conditional
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-23 06:52 EDT by Matteo Corti
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-23 06:56:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example Java class (102 bytes, text/plain)
2002-07-23 06:53 EDT, Matteo Corti
no flags Details

  None (edit)
Description Matteo Corti 2002-07-23 06:52:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020605

Description of problem:
Internal compiler error in generate_bytecode_conditional, at
../gcc/java/jcf-write.c:1300 while compiling:

 	if ((i -= 7) < 0 )


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Edit a Java class with a statement similar to
     if ((i -= 7) < 0 )
   For example

public class TestGCJ01 {
    public void foo() {
	int i;
	i = 0;
 	if ((i -= 7) < 0 )
	    ;
    }

}

2. Compile it with "gcj -C"
3. The compiler crashes
	

Actual Results:  Internal compiler error in generate_bytecode_conditional, at
../gcc/java/jcf-write.c:1300

Expected Results:  The correct Java class file

Additional info:
Comment 1 Matteo Corti 2002-07-23 06:53:39 EDT
Created attachment 66504 [details]
Example Java class
Comment 2 Matteo Corti 2002-07-23 06:56:34 EDT
Small comment update:
- the bug is _always_ reproducible (and not sometimes as mistakenly entered)
Comment 3 Jakub Jelinek 2002-07-23 07:17:29 EDT
Cannot reproduce it with gcj 3.1. Java support was just a technological preview
in 2.96-RH. Grab gcj 3.1 via RHN and you should be fine.

Note You need to log in before you can comment on or make changes to this bug.