Bug 69573 - gimp-print-cups drivers don't work
gimp-print-cups drivers don't work
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: cups (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Mike McLean
:
: 70428 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-23 08:05 EDT by Klaus Steinberger
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-19 08:28:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Klaus Steinberger 2002-07-23 08:05:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020711

Description of problem:
Cups starting with version 1.1.15 did not include the pstoraster filter, instead
it depends on ghostscript, otherwise some drivers for cups (i.e. any driver from
gimp-print-cups) will not work.

So please add the patch which is in the cups source in the directory
pstoraster to the ghostscript build, or use the modified ghostscript from ESP.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. select a printer driver in cups from gimp-print-cups (e.g. EPSON Stylus Color
680, CUPS+GIMP-print v4.2.1 (en))
2. try to print the test page
3.
	

Actual Results:  in /var/log/cups/error_log the following will be logged:
E [23/Jul/2002:14:03:34 +0200] Unable to convert file 0 to printable format for
job 178!

Additional info:
Comment 1 Tim Waugh 2002-07-23 10:09:01 EDT
We are not changing to ESP Ghostscript just yet.  Since CUPS is the only thing 
that _uses_ this utility, it belongs in the CUPS package.
Comment 2 Tim Waugh 2002-08-05 08:41:08 EDT
*** Bug 70428 has been marked as a duplicate of this bug. ***
Comment 3 Tim Waugh 2002-08-15 13:09:19 EDT
pstoraster files added in cups-1.1.15-7. 
 
Now need the cups gs device.
Comment 4 Tim Waugh 2002-08-15 14:10:59 EDT
Oops, I left a '/usr/local' path in pstoraster.  Need to change that on the 
next build. 
 
But also, I built a ghostscript with the 'cups' device, but still can't get it 
working.  Something else is wrong, since 'pstoraster' never even gets invoked 
as far as I can see. :-/
Comment 5 Tim Waugh 2002-08-16 10:32:10 EDT
Fixed ghostscript package is 7.05-20. 
 
So now two CUPS problems remain: 
 
a) my mistake in pstoraster: change 'prefix=/usr/local' to 'prefix=/usr' in 
the next CUPS build 
 
b) even after this change the gimp-print drivers don't work from CUPS, and I 
don't know why.  They work fine from LPRng.
Comment 6 Tim Waugh 2002-08-19 08:28:29 EDT
Fixed package is 1.1.15-9.  The gimp-print-cups drivers work now; probably I 
did something wrong when testing before.
Comment 7 Jay Turner 2002-08-29 08:25:07 EDT
Things look good from this end.

Note You need to log in before you can comment on or make changes to this bug.