Bug 69585 - sendmail 8.12.5-2 db map issue in .spec
sendmail 8.12.5-2 db map issue in .spec
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: sendmail (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-23 09:57 EDT by R P Herrold
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-08 11:27:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2002-07-23 09:57:14 EDT
Toward the bottom of the build, there is still a missing hash source file (this
time virtusertable ) -- which is precenting the .spec file from cleanly
rebuilding.

It also appears that the build is not chroot-ed completely, and that the false
error on the permissions on /var/tmp (which is outside [above !!] of the build
root -- should be an issue.

There was a fix on the hashing issue proposed on 2002-03-18 on ticket 61270 on
this issue -- 

-
================


+ root=..
+ '[' '!' -r /var/tmp/sendmail-root//usr/bin/../rootfile ']'
+ root=../..
+ '[' '!' -r /var/tmp/sendmail-root//usr/bin/../../rootfile ']'
+ ln -sf ../../usr/sbin/sendmail /var/tmp/sendmail-root/usr/bin/hoststat
+ ln -sf ../../usr/sbin/sendmail /var/tmp/sendmail-root/usr/bin/mailq
+ ln -sf ../../usr/sbin/sendmail /var/tmp/sendmail-root/usr/bin/newaliases
+ ln -sf ../../usr/sbin/sendmail /var/tmp/sendmail-root/usr/bin/purgestat
+ install -d -m755 /var/tmp/sendmail-root/etc/smrsh
+ cat
+ touch /var/tmp/sendmail-root/etc/mail/virtusertable
+ chmod 0644 /var/tmp/sendmail-root/etc/mail/virtusertable
+ /var/tmp/sendmail-root/usr/bin/makemap -C
/var/tmp/sendmail-root/etc/mail/sendmail.cf hash
/var/tmp/sendmail-root/etc/mail/virtusertable.db
WARNING: World writable directory /var/tmp
WARNING: World writable directory /var/tmp
makemap: error opening type hash map
/var/tmp/sendmail-root/etc/mail/virtusertable.db: Invalid argument
error: Bad exit status from /var/tmp/rpm-tmp.24796 (%install)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.24796 (%install)
[root@oldnews dl]# rpm -Uvh sendmail-8.12.5-2.src.rpm
[root@oldnews dl]#



Description of Problem:


Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Florian La Roche 2002-08-06 07:57:30 EDT
This problem does not happen for me. Where did you recompile this package?

Thanks,

Florian La Roche
Comment 2 R P Herrold 2002-08-07 22:31:20 EDT
hmmm, a RH 7.3 host which I have extensively pushed Raw Hide content into  ...
pulled Rawhide 8.12.5-5 and in building as non-root, I cannot see the previous
error when I already have 8.12.4 installed ...

BUT:  look <!!!> at the user and group choices made by the .spec file --
woefully wrong:

+ OBJDIR=obj.Linux.2.4.18-3.i686
++ id -nu
+ nameuser=herrold
++ id -ng
+ namegroup=herrold
+ Make install -C obj.Linux.2.4.18-3.i686/libmilter
+ make install -C obj.Linux.2.4.18-3.i686/libmilter
DESTDIR=/var/tmp/sendmail-root MANROOT=/usr/share/man/man SBINOWN=herrold
SBINGRP=herrold UBINOWN=herrold UBINGRP=herrold MANOWN=herrold MANGRP=herrold
INCOWN=herrold INCGRP=herrold LIBOWN=herrold LIBGRP=herrold GBINOWN=herrold
GBINGRP=herrold MSPQOWN=herrold CFOWN=herrold CFGRP=herrold
make: Entering directory
`/home/herrold/redhat/BUILD/sendmail-8.12.5/obj.Linux.2.4.18-3.i686/libmilter'
<snip>

+ Make install -C obj.Linux.2.4.18-3.i686/makemap
+ make install -C obj.Linux.2.4.18-3.i686/makemap DESTDIR=/var/tmp/sendmail-root
MANROOT=/usr/share/man/man SBINOWN=herrold SBINGRP=herrold UBINOWN=herrold
UBINGRP=herrold MANOWN=herrold MANGRP=herrold INCOWN=herrold INCGRP=herrold
LIBOWN=herrold LIBGRP=herrold GBINOWN=herrold GBINGRP=herrold MSPQOWN=herrold
CFOWN=herrold CFGRP=herrold
make: Entering directory
`/home/herrold/redhat/BUILD/sendmail-8.12.5/obj.Linux.2.4.18-3.i686/makemap'
install -c -o herrold -g herrold -m 555 makemap /var/tmp/sendmail-root/usr/sbin
make: Circular makemap.8 <- makemap.8 dependency dropped.
install -c -o herrold -g herrold -m 644 makemap.8
/var/tmp/sendmail-root/usr/share/man/man8/makemap.8
make: Leaving directory
`/home/herrold/redhat/BUILD/sendmail-8.12.5/obj.Linux.2.4.18-3.i686/makemap'
+ touch /var/tmp/sendmail-root/rootfile
+ root=..

... amazing ...

------------------------------------

I'll rebuild on an older 'virgin' host in a moment ...
Comment 3 R P Herrold 2002-08-07 22:32:20 EDT
(I say pushed -- I rebuild from SRPM and NEVER NEVER --force of --nodep contant
in from binary packages ...)
Comment 4 R P Herrold 2002-08-07 22:51:07 EDT
hmmm ... missing db4 build dependency in the .spec file ... grabbing and
retrying -- this is a reasonably untouched Red Hat Linux release 7.2 (Enigma)

a - niprop.o
a - mpeix.o
ranlib  libsm.a
cc -O2 -I. -I../../include  -DNEWDB -DNEWDB -DNIS -DHESIOD -DMAP_REGEX -DLDAPMAP
-O2 -march=i386 -mcpu=i686 -I/usr/include/db4 -Wall -DXDEBUG=0 -DTCPWRAPPERS
-DSASL -DSTARTTLS -DMILTER -DNETINET6 -DHES_GETMAILHOST -DUSE_VENDOR_CF_PATH=1
-D_FFR_WORKAROUND_BROKEN_NAMESERVERS -D_FFR_SMTP_SSL      -c -o t-event.o
t-event.c
cc -o t-event   t-event.o libsm.a   -ldb -lresolv -lcrypt -lnsl -lnsl -lwrap
-lldap -llber -lsasl -lssl -lcrypto -lhesiod -lgdbm -lcrypt -ldb-4.0
/usr/bin/ld: cannot find -ldb-4.0
collect2: ld returned 1 exit status
make[1]: *** [t-event] Error 1
make[1]: Leaving directory
`/usr/src/redhat/BUILD/sendmail-8.12.5/obj.Linux.2.4.7-10.i586/libsm'
make: ***
[/usr/src/redhat/BUILD/sendmail-8.12.5/obj.Linux.2.4.7-10.i586/libsm/libsm.a]
Error 2
error: Bad exit status from /var/tmp/rpm-tmp.24613 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.24613 (%build)
[root@clone src]# history | tail -20
   80  rpm -Uvh sendmail-8.12.5-5.src.rpm
   81  rpmbuild  -ba ./redhat/SPECS/sendmail.spec
   82  wget   --passive
ftp://ftp.owlriver.com/pub/local/ORC/sendmail/hesiod-devel*
   83  mv ftp.owlriver.com/pub/local/ORC/sendmail/hesiod-devel-3.0.2-20.i386.rpm
.
   85  rpm -Uvh hesiod-devel-3.0.2-20.i386.rpm
   86  wget -O hesiod-3.0.2-20.i386.rpm  --passive
ftp://ftp.owlriver.com/pub/local/ORC/sendmail/hesiod-3.0.2-20.i386.rpm
   87  rpm -Uvh hesiod-devel-3.0.2-20.i386.rpm hesiod-3.0.2-20.i386.rpm
   88  rm hesiod-devel-3.0.2-20.i386.rpm hesiod-3.0.2-20.i386.rpm
   89  rpmbuild  -ba ./redhat/SPECS/sendmail.spec
[root@clone src]#
Comment 5 R P Herrold 2002-08-07 23:15:28 EDT
The problem is still there with the latest from Raw Hide -- it still looking at
/var/tmp , and still dies in the makemap phase:

+ root=../..
+ '[' '!' -r /var/tmp/sendmail-root//usr/bin/../../rootfile ']'
+ ln -sf ../../usr/sbin/sendmail /var/tmp/sendmail-root/usr/bin/hoststat
+ ln -sf ../../usr/sbin/sendmail /var/tmp/sendmail-root/usr/bin/mailq
+ ln -sf ../../usr/sbin/sendmail /var/tmp/sendmail-root/usr/bin/newaliases
+ ln -sf ../../usr/sbin/sendmail /var/tmp/sendmail-root/usr/bin/purgestat
+ install -d -m755 /var/tmp/sendmail-root/etc/smrsh
+ cat
+ touch /var/tmp/sendmail-root/etc/mail/virtusertable
+ chmod 0644 /var/tmp/sendmail-root/etc/mail/virtusertable
+ /var/tmp/sendmail-root/usr/bin/makemap -C
/var/tmp/sendmail-root/etc/mail/sendmail.cf hash
/var/tmp/sendmail-root/etc/mail/virtusertable.db
WARNING: World writable directory /var/tmp
WARNING: World writable directory /var/tmp
/var/tmp/rpm-tmp.35312: line 141:  6359 Segmentation fault      (core dumped)
$RPM_BUILD_ROOT/usr/bin/makemap -C $RPM_BUILD_ROOT/etc/mail/sendmail.cf hash
$RPM_BUILD_ROOT/etc/mail/${map}.db <$RPM_BUILD_ROOT/etc/mail/${map}
error: Bad exit status from /var/tmp/rpm-tmp.35312 (%install)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.35312 (%install)
[root@clone src]# df
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/hda3               632476    571224     29124  96% /
/dev/hda1                77750      5437     68299   8% /boot
/dev/hda6              1185872    853768    271864  76% /usr
/dev/hda7               790556    210840    539556  29% /var
/dev/hda8               388693      8424    360190   3% /tmp
none                     63388         0     63388   0% /dev/shm
[root@clone src]# rpm -qa | grep db4
db4-4.0.14-4
db4-devel-4.0.14-4
[root@clone src]#
Comment 6 R P Herrold 2002-08-07 23:21:16 EDT
Here is the driver file ...


[root@clone src]# nl /var/tmp/rpm-tmp.35312
     1  #!/bin/sh

     2    RPM_SOURCE_DIR="/usr/src/redhat/SOURCES"
     3    RPM_BUILD_DIR="/usr/src/redhat/BUILD"
     4    RPM_OPT_FLAGS="-O2 -march=i386 -mcpu=i686"
     5    RPM_ARCH="i386"
     6    RPM_OS="linux"
     7    export RPM_SOURCE_DIR RPM_BUILD_DIR RPM_OPT_FLAGS RPM_ARCH RPM_OS
     8    RPM_DOC_DIR="/usr/share/doc"
     9    export RPM_DOC_DIR
    10    RPM_PACKAGE_NAME="sendmail"
    11    RPM_PACKAGE_VERSION="8.12.5"
    12    RPM_PACKAGE_RELEASE="5"
    13    export RPM_PACKAGE_NAME RPM_PACKAGE_VERSION RPM_PACKAGE_RELEASE
    14    RPM_BUILD_ROOT="/var/tmp/sendmail-root"
    15    export RPM_BUILD_ROOT
    16
    17    set -x
    18    umask 022
    19    cd /usr/src/redhat/BUILD
    20  cd sendmail-8.12.5
    21  rm -rf $RPM_BUILD_ROOT
    22  mkdir -p $RPM_BUILD_ROOT

    23  cd $RPM_BUILD_ROOT
    24  mkdir -p etc/sysconfig $RPM_BUILD_ROOT/etc/rc.d/init.d etc/pam.d
    25  mkdir -p usr/bin usr/include/libmilter usr/lib
./usr/share/man/man{1,5,8} usr/sbin var/log
    26  mkdir -p var/spool usr/share/sendmail-cf
    27  cd -

    28  OBJDIR=obj.$(uname -s).$(uname -r).$(arch)

    29  nameuser=`id -nu`
    30  namegroup=`id -ng`
    31  Make() {
    32          make $@ \
    33                  DESTDIR=$RPM_BUILD_ROOT \
    34                  MANROOT=/usr/share/man/man \
    35                  SBINOWN=${nameuser} \
    36                  SBINGRP=${namegroup} \
    37                  UBINOWN=${nameuser} \
    38                  UBINGRP=${namegroup} \
    39                  MANOWN=${nameuser} \
    40                  MANGRP=${namegroup} \
    41                  INCOWN=${nameuser} \
    42                  INCGRP=${namegroup} \
    43                  LIBOWN=${nameuser} \
    44                  LIBGRP=${namegroup} \
    45                  GBINOWN=${nameuser} \
    46                  GBINGRP=${namegroup} \
    47                  MSPQOWN=${nameuser} \
    48                  CFOWN=${nameuser} \
    49                  CFGRP=${namegroup}
    50  }

    51  Make install -C $OBJDIR/libmilter
    52  Make install -C $OBJDIR/libsmutil
    53  Make install -C $OBJDIR/sendmail
    54  Make install -C $OBJDIR/mailstats
    55  Make install -C $OBJDIR/praliases
    56  Make force-install -C $OBJDIR/rmail
    57  Make install -C $OBJDIR/smrsh
    58  Make install -C $OBJDIR/makemap

    59  touch $RPM_BUILD_ROOT/rootfile
    60  root=..
    61  while [ ! -r $RPM_BUILD_ROOT//usr/bin/${root}/rootfile ] ; do
    62          root=${root}/..
    63  done
    64  ln -sf ${root}/usr/sbin/makemap $RPM_BUILD_ROOT//usr/bin/makemap

    65  # Install docs by hand for the sendmail-doc package.
    66  DOC=$RPM_BUILD_ROOT/usr/share/doc/sendmail
    67  mkdir -p $DOC
    68  cp -ar FAQ LICENSE KNOWNBUGS README RELEASE_NOTES doc $DOC
    69  cp sendmail/README   $DOC/README.sendmail
    70  cp sendmail/SECURITY $DOC/SECURITY
    71  cp smrsh/README      $DOC/README.smrsh
    72  cp libmilter/README  $DOC/README.libmilter
    73  cp cf/README         $DOC/README.cf
    74  cp /usr/src/redhat/SOURCES/sendmail-8.12.5-newconfig.readme       
$DOC/README.redhat

    75  # Install the cf files for the sendmail-cf package.
    76  cp -ar cf/* $RPM_BUILD_ROOT/usr/share/sendmail-cf

    77  install -d -m755 $RPM_BUILD_ROOT/etc/mail

    78  sed -e 's|@@PATH@@|/usr/share/sendmail-cf|' <
/usr/src/redhat/SOURCES/sendmail-redhat.mc >
$RPM_BUILD_ROOT/etc/mail/sendmail.mc

    79  sed -e 's|/usr/share/sendmail-cf|\.\.|' <
$RPM_BUILD_ROOT/etc/mail/sendmail.mc > cf/cf/redhat.mc
    80  (cd cf/cf && m4 redhat.mc > redhat.cf)
    81  install -m 644 cf/cf/redhat.cf $RPM_BUILD_ROOT/etc/mail/sendmail.cf
    82  install -m 644 cf/cf/submit.mc $RPM_BUILD_ROOT/etc/mail/submit.mc

    83  echo "# local-host-names - include all aliases for your machine here." >
$RPM_BUILD_ROOT/etc/mail/local-host-names
    84  ( echo "# trusted-users - users that can send mail as others without a
warning"
    85  echo "# apache, mailman, majordomo, uucp, are good candidates" ) \
    86          > $RPM_BUILD_ROOT/etc/mail/trusted-users


    87  touch $RPM_BUILD_ROOT/rootfile
    88  root=..
    89  while [ ! -r $RPM_BUILD_ROOT//usr/lib/${root}/rootfile ] ; do
    90          root=${root}/..
    91  done
    92  #ln -sf ${root}/usr/sbin/sendmail $RPM_BUILD_ROOT//usr/lib/sendmail
    93  ln -sf ../sbin/sendmail $RPM_BUILD_ROOT//usr/lib/sendmail
    94  install -d -m775 $RPM_BUILD_ROOT/var/spool/mqueue
    95  install -d -m755 $RPM_BUILD_ROOT/var/spool/clientmqueue

    96  # dangling symlinks
    97  touch $RPM_BUILD_ROOT/rootfile
    98  root=..
    99  while [ ! -r $RPM_BUILD_ROOT//usr/bin/${root}/rootfile ] ; do
   100          root=${root}/..
   101  done
   102  for f in hoststat mailq newaliases purgestat
   103    do
   104      ln -sf ${root}/usr/sbin/sendmail $RPM_BUILD_ROOT/usr/bin/${f}
   105    done
   106  install -d -m755 $RPM_BUILD_ROOT/etc/smrsh

   107  cat <<EOF > $RPM_BUILD_ROOT/etc/mail/access
   108  # Check the /usr/share/doc/sendmail/README.cf file for a description
   109  # of the format of this file. (search for access_db in that file)
   110  # The /usr/share/doc/sendmail/README.cf is part of the sendmail-doc
   111  # package.
   112  #
   113  # by default we allow relaying from localhost...
   114  localhost.localdomain           RELAY
   115  localhost                       RELAY
   116  127.0.0.1                       RELAY

   117  EOF
   118  for map in virtusertable access domaintable mailertable
   119    do
   120      touch $RPM_BUILD_ROOT/etc/mail/${map}
   121      chmod 0644 $RPM_BUILD_ROOT/etc/mail/${map}
   122      $RPM_BUILD_ROOT/usr/bin/makemap -C
$RPM_BUILD_ROOT/etc/mail/sendmail.cf hash $RPM_BUILD_ROOT/etc/mail/${map}.db <
$RPM_BUILD_ROOT/etc/mail/${map}
   123      chmod 0644 $RPM_BUILD_ROOT/etc/mail/${map}.db
   124    done
   125  install -m644 /usr/src/redhat/SOURCES/aliases
$RPM_BUILD_ROOT/etc/aliases
   126  $RPM_BUILD_ROOT/usr/bin/makemap -C $RPM_BUILD_ROOT/etc/mail/sendmail.cf
hash $RPM_BUILD_ROOT/etc/aliases.db < /usr/src/redhat/SOURCES/aliases

   127  install -m644 /usr/src/redhat/SOURCES/sendmail.sysconfig
$RPM_BUILD_ROOT/etc/sysconfig/sendmail
   128  install -m755 /usr/src/redhat/SOURCES/sendmail.init
$RPM_BUILD_ROOT/etc/rc.d/init.d/sendmail

   129  install -m 644 /usr/src/redhat/SOURCES/sendmail.etc-mail-Makefile
$RPM_BUILD_ROOT/etc/mail/Makefile

   130  chmod u+w $RPM_BUILD_ROOT/usr/sbin/{mailstats,praliases}
   131  chmod u+w $RPM_BUILD_ROOT/usr/bin/rmail

   132  # strip $RPM_BUILD_ROOT/usr/sbin/{mailstats,praliases,sendmail}
   133  # strip $RPM_BUILD_ROOT/usr/bin/rmail

   134  install -m755 -d $RPM_BUILD_ROOT/usr/lib/sasl
   135  install -m 644 /usr/src/redhat/SOURCES/Sendmail.conf
$RPM_BUILD_ROOT/usr/lib/sasl/Sendmail.conf
   136  install -m 644 /usr/src/redhat/SOURCES/sendmail.pam
$RPM_BUILD_ROOT/etc/pam.d/smtp

   137  install -m 755 -d $RPM_BUILD_ROOT/usr/lib
   138  install -m 644  $OBJDIR/libmilter/libmilter.a $RPM_BUILD_ROOT/usr/lib
   139  install -m 644  $OBJDIR/libsmutil/libsmutil.a $RPM_BUILD_ROOT/usr/lib
   140  install -m 644  $OBJDIR/libsm/libsm.a         $RPM_BUILD_ROOT/usr/lib

   141  mv $RPM_BUILD_ROOT/usr/sbin/sendmail
$RPM_BUILD_ROOT/usr/sbin/sendmail.sendmail
   142  for i in mailq newaliases rmail; do
   143          mv $RPM_BUILD_ROOT/usr/bin/$i
$RPM_BUILD_ROOT/usr/bin/$i.sendmail
   144  done
   145  mv $RPM_BUILD_ROOT/usr/share/man/man1/mailq.1
$RPM_BUILD_ROOT/usr/share/man/man1/mailq.sendmail.1
   146  mv $RPM_BUILD_ROOT/usr/share/man/man1/newaliases.1
$RPM_BUILD_ROOT/usr/share/man/man1/newaliases.sendmail.1
   147  mv $RPM_BUILD_ROOT/usr/share/man/man5/aliases.5
$RPM_BUILD_ROOT/usr/share/man/man5/aliases.sendmail.5


   148
   149
   150      /usr/lib/rpm/brp-compress
   151      /usr/lib/rpm/brp-strip
   152      /usr/lib/rpm/brp-strip-comment-note

=================================

hmmm ... lotta whitespace in the build file:

[root@clone src]# grep -v ^\ .*$ < /var/tmp/rpm-tmp.35312  | nl | tail
   114  mv $RPM_BUILD_ROOT/usr/sbin/sendmail
$RPM_BUILD_ROOT/usr/sbin/sendmail.sendmail
   115  for i in mailq newaliases rmail; do
   116          mv $RPM_BUILD_ROOT/usr/bin/$i
$RPM_BUILD_ROOT/usr/bin/$i.sendmail
   117  done
   118  mv $RPM_BUILD_ROOT/usr/share/man/man1/mailq.1
$RPM_BUILD_ROOT/usr/share/man/man1/mailq.sendmail.1
   119  mv $RPM_BUILD_ROOT/usr/share/man/man1/newaliases.1
$RPM_BUILD_ROOT/usr/share/man/man1/newaliases.sendmail.1
   120  mv $RPM_BUILD_ROOT/usr/share/man/man5/aliases.5
$RPM_BUILD_ROOT/usr/share/man/man5/aliases.sendmail.5

Comment 7 R P Herrold 2002-08-07 23:24:03 EDT
Is the build possibly using the 'wrong' makemap (i.e., not the newly created
one), but rather one from a prior version?  no absolute path to the makemap
seems to exist...

bash-2.05a$ which makemap
/usr/sbin/makemap
bash-2.05a$ rpm -qf /usr/sbin/makemap
sendmail-8.12.4-1
bash-2.05$ 

Comment 8 Florian La Roche 2002-08-08 07:55:03 EDT
An absolute path for this makemap is used. It also rebuilds fine for me
on a current rawhide version. I just notice that your db4 is a bit older.
I have release "11" on my machine.

greetings,

Florian La Roche
Comment 9 R P Herrold 2002-08-08 10:09:26 EDT
interesting on the db4 -- I will bounce versions and retest --
Comment 10 R P Herrold 2002-08-08 11:27:17 EDT
fascinating -- that seems to be it:

rpmlib(CompressedFileNames) <= 3.0.4-1
Processing files: sendmail-cf-8.12.5-5
Finding  Provides: (using /usr/lib/rpm/find-provides)...
Finding  Requires: (using /usr/lib/rpm/find-requires)...
PreReq: rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <=
3.0.4-1
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
Requires: /bin/sh
Wrote: /usr/src/redhat/SRPMS/sendmail-8.12.5-5.src.rpm
Wrote: /usr/src/redhat/RPMS/i386/sendmail-8.12.5-5.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/sendmail-doc-8.12.5-5.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/sendmail-devel-8.12.5-5.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/sendmail-cf-8.12.5-5.i386.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.11943
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd sendmail-8.12.5
+ rm -rf /var/tmp/sendmail-root
+ exit 0
[herrold@clone herrold]$ rpm -qa | grep db
db1-devel-1.85-7
gdbm-1.8.0-10
gdbm-devel-1.8.0-10
db31-3.1.17-1
gdb-5.2-2
db4-utils-4.0.14-11
xxgdb-1.12-10
pwdb-0.61.1-3
db1-1.85-7
db3-3.2.9-4
db4-devel-4.0.14-11
db2-2.4.14-7
nss_db-2.2-6
db4-4.0.14-11
[herrold@clone herrold]$ rpm -qa | grep hes
hesiod-devel-3.0.2-20
hesiod-3.0.2-20
[herrold@clone herrold]$ rpm -qa | grep send
sendmail-cf-8.11.6-3
sendmail-doc-8.11.6-3
sendmail-8.11.6-3
[herrold@clone herrold]$

OK by me for a RAWHIDE close -- but you may want to version the db-devel
BuildRequires ...

-- Russ
Comment 11 Florian La Roche 2002-08-29 17:38:11 EDT
This should be fixed an ok.

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.