Bug 69647 - binaries are hardcoded with the wrong config directory
binaries are hardcoded with the wrong config directory
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: netatalk (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
: 71002 74636 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-23 23:22 EDT by Need Real Name
Modified: 2015-03-04 20:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-23 23:27:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-23 23:22:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530

Description of problem:
Config info for afpd in /etc/atalk/afpd.conf is ignored as the program
looks in /usr/etc/netatalk.

$ strings /usr/sbin/afpd | grep afpd.conf
/usr/etc/netatalk/afpd.conf


Version-Release number of selected component (if applicable):
1.5.2-3


How reproducible:
Always

Steps to Reproduce:
1. Change config in /etc/atalk/afpd.conf
2. Run /etc/rc.d/init.d/atalk restart
	

Actual Results:  Configured Servers fail to appear

Expected Results:  Well they should be registered!

Additional info:

The fix is to add --with-pkgconfdir=/etc/atalk to the spec file and
rebuild the package (see below).

%build
CFLAGS="$RPM_OPT_FLAGS -fsigned-char" ./configure --prefix=%{_prefix} \
        --with-cracklib --with-pam --with-shadow --with-tcp-wrappers \
        --with-ssl --with-flock-locksi --with-uams-path=%{_libdir} \
        --with-pkgconfdir=/etc/atalk

Alternatively add the -F /etc/atalk/afpd.conf to the init script.  Note that the
-F switch is not in the man page.

Doug
Comment 1 Need Real Name 2002-07-23 23:26:57 EDT
After reconfiguring with --with-pkgconfdir=/etc/atalk

$ strings afpd | grep /etc/atalk
/etc/atalk/afpd.conf
/etc/atalk/nls/
/etc/atalk/afppasswd
/etc/atalk/AppleVolumes.default
/etc/atalk/AppleVolumes.system
Comment 2 Phil Knirsch 2002-08-07 10:44:46 EDT
Fixed in latest netatalk-1.5.3.1-4 package available via rawhide.

Read ya, Phil
Comment 3 Phil Knirsch 2002-08-08 07:29:02 EDT
*** Bug 71002 has been marked as a duplicate of this bug. ***
Comment 4 Phil Knirsch 2002-09-28 02:43:22 EDT
*** Bug 74636 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.