Bug 69656 - GUI: downloads silently w/ no progress bar
GUI: downloads silently w/ no progress bar
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-24 02:43 EDT by Michael Schwendt
Modified: 2015-01-07 18:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-08 17:04:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2002-07-24 02:43:17 EDT
From Bugzilla Helper:  
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)  
  
Description of problem:  
Similar to the weird progress bar behaviour in text mode, the GUI up2date downloads the first  
package silently without refreshing the dialog and progress bar. Progress bars don't work 
satisfactory at all. 
  
Version-Release number of selected component (if applicable):  
Limbo from scratch with:  
rhnlib-0.8-11  
up2date-2.9.20-7.x.9  
up2date-gnome-2.9.20-7.x.9  
  
How reproducible:  
Always  
  
Steps to Reproduce:  
Use above versions of up2date to upgrade a big package (e.g. the kernel) or the first several  
hundred packages for Limbo.  
  
Actual Results:    
/usr/share/rhn/up2date_client/gui.py:1414: DeprecationWarning:   
  totalProgress.update(0)  
/usr/share/rhn/up2date_client/gui.py:1377: DeprecationWarning:   
  self.progress.update(i)  
/usr/share/rhn/up2date_client/gui.py:1467: DeprecationWarning:   
  totalProgress.update(i)  
 /usr/share/rhn/up2date_client/gui.py:1570: DeprecationWarning:  
  self.totalProgress.update(0) 
/usr/share/rhn/up2date_client/gui.py:1544: DeprecationWarning:  
  self.progress.update(i) 
 
And this one for each package:  
  
(up2date:20101): Gtk-CRITICAL **: file gtkprogress.c: line 550 (gtk_progress_set_percentage):  
assertion `percentage >= 0 && percentage <= 1.0' failed  
  
  
Expected Results:  Working progress bars during download.  
  
 
Additional info: "Total progress" stays at 0%. When the last package was downloaded, the 
dialog just sits there without telling the user it is done. Clicking "Forward" works, though.
Comment 1 Adrian Likins 2002-07-24 03:39:16 EDT
I think at the moment, there is a bug in rhnlib that is causing 
me to never get progress callbacks.

The cli client isnt ever drawing it's hash progress bars either,
even though, as best I can tell, everything is hooked up correctly.

Comment 2 Michael Schwendt 2002-08-01 10:49:57 EDT
I consider this fixed as of 2.9.30-7.x.9 (pristine Limbo beta2).

One thing is left, though, and that is, during download I get the word "blipppy"
printed in console each second. Looks like you've left related debug code in there:

/usr/share/rhn/up2date_client/gui.py:1408: DeprecationWarning: 
  totalProgress.update(0)
blipppy
/usr/share/rhn/up2date_client/gui.py:1371: DeprecationWarning: 
  self.progress.update(i)
blipppy
blipppy
blipppy
blipppy
blipppy
blipppy
blipppy
blipppy
blipppy
Comment 3 Adrian Likins 2002-08-08 17:04:44 EDT
this should both be gone in 2.9.38 or higher

blippy!
Comment 4 Jay Turner 2002-09-04 21:44:10 EDT
Fix confirmed with up2date-3.0.4-1.

Note You need to log in before you can comment on or make changes to this bug.