Bug 696714 - DiskLabelCommitError: Could not commit to disk /dev/sdc
DiskLabelCommitError: Could not commit to disk /dev/sdc
Status: CLOSED DUPLICATE of bug 575057
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2011-04-14 13:35 EDT by Stefan Gies
Modified: 2011-04-27 13:51 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-04-27 13:51:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Attached traceback automatically from anaconda. (485.99 KB, text/plain)
2011-04-14 13:35 EDT, Stefan Gies
no flags Details

  None (edit)
Description Stefan Gies 2011-04-14 13:35:52 EDT
The following was filed automatically by anaconda:
anaconda 14.22 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/formats/disklabel.py", line 250, in commit
    raise DiskLabelCommitError(msg)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devices.py", line 1390, in destroy
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 219, in execute
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 705, in processActions
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 313, in doIt
  File "/usr/lib/python2.7/site-packages/pyanaconda/packages.py", line 110, in turnOnFilesystems
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 131, in gotoNext
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1190, in nextClicked
DiskLabelCommitError: Could not commit to disk /dev/sdc
Comment 1 Stefan Gies 2011-04-14 13:35:58 EDT
Created attachment 492177 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2011-04-14 14:02:50 EDT
F14 is really pretty old at this point.  Please retest with F15 beta and let us know if this is still a problem.  Thanks.
Comment 3 Stefan Gies 2011-04-14 14:37:41 EDT
This error occured because I use an ITE8212f PCI-Controller. This error vanishes if I use a different ide-controller (e.g. sil0680a-chipset). Using Debian 6.01a or Opensuse 11.4 this error do not happen with the ITE8212f-Controller.
Comment 4 Chris Lumens 2011-04-14 22:10:50 EDT
anaconda doesn't care about disk controllers.  Reassigning.
Comment 5 Chuck Ebbert 2011-04-22 01:35:36 EDT
Anaconda is doing a FLUSH_CACHE command on the disk, and some controllers don't support that. Can't it just ignore the error if it's -EOPNOTSUPP ??
Comment 6 David Lehman 2011-04-25 16:31:54 EDT
Anaconda does not do SCSI commands. The kernel does.
Comment 7 David Lehman 2011-04-25 16:38:06 EDT
This is happening at a level lower than anaconda. It may be a kernel problem or perhaps a parted problem, but most certainly not anaconda.

Reassigning again. If it gets sent back again it will be promptly closed.
Comment 8 Chuck Ebbert 2011-04-26 21:31:28 EDT
(In reply to comment #6)
> Anaconda does not do SCSI commands. The kernel does.

The kernel is doing exactly what it is supposed to do: it's reporting that the device does not support FLUSH CACHE. This is not necessarily an error.
Comment 9 Brian Lane 2011-04-27 13:51:26 EDT
This is a dupe of bug 575057, I also found this LKML thread http://lkml.org/lkml/2010/9/23/294

*** This bug has been marked as a duplicate of bug 575057 ***

Note You need to log in before you can comment on or make changes to this bug.