Bug 696759 - upstart: [RFE] Improve "shutdown" manpage
upstart: [RFE] Improve "shutdown" manpage
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: upstart (Show other bugs)
6.1
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Petr Lautrbach
qe-baseos-daemons
: FutureFeature, ManPageChange, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-14 15:30 EDT by J.H.M. Dassen (Ray)
Modified: 2013-07-03 00:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-08 05:05:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description J.H.M. Dassen (Ray) 2011-04-14 15:30:03 EDT
2. What is the nature and description of the request?

Request that the manpage of shutdown be changed to be less confusing.
Specifically, change details regarding "-H" and "-P" option. The man page says
that it sets the halt action to "halt" but it does not mention that it should
be called with "-h" option.

 3. Why does the customer need this? (List the business requirements here)

Client has two cases where users run 
shutdown -P now 
or 
shutdown -H now
to halt/poweroff the system. 
Is it possible to clarify on the man page that "-H" and "-P" should be called
with "-h" to actually shutdown

 4. How would the customer like to achieve this? (List the functional
requirements here)

Simple documentation (man page) change

 5. For each functional requirement listed in question 4, specify how Red Hat
and the customer can test to confirm the requirement is successfully
implemented.

N/A -- Documentation change

 6. Is there already an existing RFE upstream or in Red Hat bugzilla?

I did not see one.

 7. How quickly does this need resolved? (desired target release)

Minor release.

 8. Does this request meet the RHEL Inclusion criteria (please review)

Yes

 9. List the affected packages

upstart

10. Would the customer be able to assist in testing this functionality if
implemented?

Testing should not be required--this is a documentation change.
Comment 3 RHEL Product and Program Management 2011-07-05 20:57:14 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 5 Ivana Varekova 2011-07-07 03:52:19 EDT
Please, Petr do you have a patch against this issue? If yes can you put it here I can fix this issue using man-pages-overrides process in 6.2.
Comment 7 Petr Lautrbach 2011-07-07 05:13:08 EDT
Sorry for late response.

> The man page says that it sets the halt action to "halt" but it does 
> not mention that it should be called with "-h" option.

There is no need to use -h option with -H or -P, these options implies -h, 
see shutdown --help:

  -h                          halt or power off after shutdown
  -H                          halt after shutdown (implies -h)
  -P                          power off after shutdown (implies -h)

# rpm -q upstart
upstart-0.6.5-10.1.el6.x86_64

# shutdown -P now
...
Halting system...
Power down.

# shutdown -H now
...
Halting system...
System halted.

Note You need to log in before you can comment on or make changes to this bug.