Bug 696834 - Choose format icon
Choose format icon
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Unspecified
unspecified Severity unspecified
: 3.0
: ---
Assigned To: Isaac Rooskov
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-14 20:25 EDT by Rebecca Newton
Modified: 2015-07-13 00:49 EDT (History)
5 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 23:11:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rebecca Newton 2011-04-14 20:25:58 EDT
Description of problem:
On the staging server and docs.redhat.com, the new dropdown box for choosing a format is blocking the ends of some of the longer book names. For e.g, Enterprise Web Server/ Hibernate Entity Manager User Guide. Perhaps the book names need to split lines once they reach the edge of the side bar.

Also, having ePub first on the list of formats results in this being clicked more often, and I think it is not the most popular format. I think it is because instinctively, I at least, *click* the box, but it's actually a hover-menu.

Version-Release number of selected component (if applicable):


How reproducible:
Visit the stage.
Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
- The book names wrap to the next line
- The side bar is expanded to fit the text.
- html-single or something more popular is the first on the list of the dropdown box.

Additional info:
Comment 1 Jared MORGAN 2011-05-12 23:57:41 EDT
I would like to see HTML Single made the default view. It is better for full-book searching.
Comment 2 Misty Stanley-Jones 2011-05-13 00:03:43 EDT
(In reply to comment #1)
> I would like to see HTML Single made the default view. It is better for
> full-book searching.

I suspect this is not the default because there are some books that are too large to view in html-single, such as the RHEL Deployment Guide. Also, there are a few books that do not have a html-single built at all, apparently.
Comment 3 Jeff Fearn 2012-03-15 03:35:52 EDT
Reworked web_style 1 to wrap long names, changed drop down to funky slider.

To ssh://git.fedorahosted.org/git/publican.git
   8d1c0c5..3c7fdf0  master -> master
Comment 4 Tomas Capek 2012-04-26 12:59:47 EDT
Verified that long names wrap correctly in the side bar and that the slide menu with format options works.

Note You need to log in before you can comment on or make changes to this bug.