Bug 69685 - While trying to install, an unhandled exception occured.
While trying to install, an unhandled exception occured.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-24 10:07 EDT by Need Real Name
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-03 19:43:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda Traceback and error dump (78.06 KB, text/plain)
2002-08-02 11:40 EDT, robert
no flags Details
Comment (66.59 KB, text/plain)
2002-07-24 10:07 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-07-24 10:07:11 EDT
Created attachment 915111 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 1 Need Real Name 2002-07-27 10:29:04 EDT
I get exactly the same crash trace on a no-name PC installing onto a fresh hard disk. I've tried 
installing four or five times using different options and each and every time I get the same 
problem.
-- 
-|merio.
red_hat_man@rival.clara.co.uk
Comment 2 Need Real Name 2002-07-27 11:42:42 EDT
First, media checked CDs and checked MD5 sums (have two sets of self made CDs) and all OK. One set 
has had one successfull installation on a low end no-name PC. 

Second, having tried several 
sets of different options on two PCs no less, the problem remains. Whilst reading some of the bug 
reports, all effectively reporting the same problem, I have evolved a work-around. 

WORK-
AROUND

Once the first installation has failed as per the bug, simply re-run the and do an 
upgrade, not a fresh install. This completes the installation after a fahsion, but not to the 
original option set. Make a boot floppy diskette and use that to boot your new install; then 
perform the necessary fix-ups to complete install, e.g. boot loader, etc. Its a pain but it gets 
the system there eventually.

INTERSTING for RED HAT DEV TEAM (maybe)

The upgrade 
continues where the original crash occurred, i.e. the install of the openjade package. It seems 
that the crash may be _coincident_ with the installers request (or fail to request) a CD change 
from disk 1 to disk 2. Does this help? Let me know if you want any further info.

-- 
-
|merio.
red_hat_man@rival.clara.co.uk
Comment 3 Need Real Name 2002-07-27 11:43:03 EDT
First, media checked CDs and checked MD5 sums (have two sets of self made CDs) and all OK. One set 
has had one successfull installation on a low end no-name PC. 

Second, having tried several 
sets of different options on two PCs no less, the problem remains. Whilst reading some of the bug 
reports, all effectively reporting the same problem, I have evolved a work-around. 

WORK-
AROUND

Once the first installation has failed as per the bug, simply re-run the and do an 
upgrade, not a fresh install. This completes the installation after a fahsion, but not to the 
original option set. Make a boot floppy diskette and use that to boot your new install; then 
perform the necessary fix-ups to complete install, e.g. boot loader, etc. Its a pain but it gets 
the system there eventually.

INTERSTING for RED HAT DEV TEAM (maybe)

The upgrade 
continues where the original crash occurred, i.e. the install of the openjade package. It seems 
that the crash may be _coincident_ with the installers request (or fail to request) a CD change 
from disk 1 to disk 2. Does this help? Let me know if you want any further info.

-- 
-
|merio.
red_hat_man@rival.clara.co.uk
Comment 4 Need Real Name 2002-08-01 13:38:35 EDT
Second workaround. Install to a primary drive/partition rather than a secondary 
drive or 'other' partition. The problem fails to materialise.

Please also note that bugzilla has had at least 10 plus occurance of this or 
similar issues.
-- 
-|merio.
red_hat_man@rival.clara.co.uk
Comment 5 robert 2002-08-02 11:40:29 EDT
Created attachment 68485 [details]
anaconda Traceback and error dump
Comment 6 robert 2002-08-02 11:54:29 EDT
Looks like same problem, installation halted abnormally in RedHat 7.3 Linux
install from CDs, CDs purchased from RedHat.  anaconda Traceback seems to be
exactly the same as  
above, but I have attached contents of dump if you want to check in detail.

Hardware:

Somewhat older Dell XPS H233, purchased about 8/97.
Bios 1.00.02.DT0J (A01)
pentium II chip, 266MHz, 512KB
128MB Ram
3com 3c590 PCI ethernet card
Adaptec AHA-2940 Ultra SCSI
4GB EIDE hard drive
Microsoft Intellimouse
Dell 1028L monitor
Number 9 FX Motion 711, 2MB RAM video card
Scsi hard drive attached, Seagate something

Hit the same problem 3 times, twice in graphics install, once in text mode.
Seems like problem occurs at exactly the same place, close to end of 
installation of rpm files from 2nd installation disk.  Hung during
installation of file w3c-libwww-devel-5.3.25.  There was about 4MB
remaining of 1600 or so MB total in the install.

I was getting several CDROM read errors during the installation from
2nd installation CD, before the abnormal halt.  This happened all 3 
times I tried the install, always on the 2nd installation CD, not
on the first one.  Obviously could be problems with 2nd CD, but I used this same
CD set to install RedHat 7.3 on three other machines with no trouble.  (So,
obviously could be problem with my CDROM reader on this machine, although as I
said, it read the first installation CD without any trouble).  I worked through
the read errors
by hitting return several times (as the message on the screen told me to do),
whereupon it proceeded.  I also noticed that the read errors always seemed to
occur at the beginning of an rpm package, never during the the actual
installation of that package. 

After I dumped error message to disk (see attachment) it said it was safe
to reboot, which I did, ended up with a grub> prompt, seems to have some
kind of minimal system installed.  I'm going to follow the workaround suggested
above, and
try to reinstall in upgrade mode.
Comment 7 Michael Fulbright 2002-08-02 14:52:49 EDT
Please test your CDs following these instructions:

   http://people.redhat.com/~msf/mediacheck.html
Comment 8 robert 2002-08-02 17:07:49 EDT
OK, I ran the media check on all 3 of my CD's, they all came out clean.  So I
don't know why I was getting read errors on CD #2.  I did this media check on
the same machine (same CDROM reader) as the one that was giving errors.
Comment 9 robert 2002-08-03 19:43:48 EDT
About Workarounds...the one suggeted above (to do an upgrade on top of the
incomplete install) did not work for me, I had the same error on the upgrade as
I had had previously on the install.

Instead I copied the contents of my Installation CDs to another computer (a web
server), made a boot disk, and then did a web-based http installation.  Worked
easily.    See instructions in the installation guide and in the README file on
the Installation CDs.  Of course this won't work if you don't have another
computer (or a web server you can put 1.5 GB onto).  Send me an email if you
have any questions about this.
Comment 10 Michael Fulbright 2002-08-13 11:10:10 EDT
I've seen dozens of these situtations where a CD is intermittent on one machine
and works fine on others. The mediacheck is not a necessarily an accurate
measure of how well the CD will work during an install, which has a different
access pattern. I've been thinking about how to correct this but haven't had time.

Glad to hear its working now.

Note You need to log in before you can comment on or make changes to this bug.