Bug 697235 - request smartmontools upgrade to 5.40 to support 3ware 9750 RAID
request smartmontools upgrade to 5.40 to support 3ware 9750 RAID
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: smartmontools (Show other bugs)
6.0
All Unspecified
high Severity high
: rc
: ---
Assigned To: Michal Hlavinka
qe-baseos-daemons
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-16 23:09 EDT by Eric Smith
Modified: 2012-06-20 08:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: smartmontools-5.42-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:55:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Smith 2011-04-16 23:09:09 EDT
Description of problem:

Smartmontools 5.39 as supplied with RHEL 6 does not support SATA disks on a 3ware 9750 RAID controller.  Smartmontools 5.40 does have support for this.

Version-Release number of selected component (if applicable):
smartmontools-5.39.1-2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. install a 3ware 9750 card with a SATA drive on port 0
2. smartctl -d 3ware,0 /dev/twl0
  
Actual results:
smartctl 5.39.1 2010-01-28 r3054 [x86_64-redhat-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

Smartctl: Device Read Identity Failed (not an ATA/ATAPI device)

Expected results:
smartctl 5.40 2010-10-16 r3189 [x86_64-redhat-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF INFORMATION SECTION ===
Model Family:     Hitachi Deskstar 7K2000
[etc.]

Additional info:
I have rebuilt the most recent Fedora 14 SRPM for Smartmontools with no changes on RHEL6, and it solves this problem.
Comment 2 RHEL Product and Program Management 2011-04-17 02:00:09 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 4 Eric Smith 2011-05-30 00:40:58 EDT
Fixed in RHEL 6.1, smartmontools-5.40-5.el6
Comment 10 errata-xmlrpc 2012-06-20 08:55:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0803.html

Note You need to log in before you can comment on or make changes to this bug.